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Chapter 1
Introduction

Corpse (Course Planning and Setting software) is a computer based facility which
can assist in the development of quality orienteering courses.

Corpse uses a computer image of the orienteering map to enable courses to be de-
veloped interactively on a computer. This map image can be sourced from scanning
an existing map or exporting a map image out of OCAD.

All courses for an event are plotted directly “over” the map image. This enables the
course planner to quickly see the interaction between courses and the suitability of
sharing controls between courses. It also enables the course planner to quickly try
“what if” scenarios, e.g. what is the course length if a control is added to a course or
moved to another location. This is an invaluable teaching aid when demonstrating
the nuances of course setting to the new course setter.

Corpse facilitates change by rippling the change through all affected courses. For
example, a control’s number or description can be changed and all control descrip-
tion sheets are automatically updated.

Disclaimer

Corpse is a tool only. Good orienteering courses cannot be developed from the
armchair; course setters must visit control sites to confirm their suitability. While
Corpse can aid in the course planning and printing process, it cannot guarantee
that the right control is put in the right place. Furthermore, Corpse does not have
any intuitive powers; it cannot identify what feature the control circle is centred on
and cannot prevent you from describing a watercourse as a termite mound in the
control descriptions sheet.

Manual Conventions

The following typographical conventions are used throughout this manual:
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text Indicates a menu or speed button on the screen.
text » text Indicates a menu hierarchy.

text Reference to another part of this manual, which may be clicked
on when viewing on a computer.

texi Indicates an option or section on the screen.

(key) Indicates a key on the keyboard, e.g. (Alt).

+ Two or more concurrent actions, e.g. (Ctrl)+(End)+(Del).

(click) Click the designated mouse button.

Licence Agreement

Copyright (C) 2011 by Rex Saye and Robert Saye. All rights reserved.
CORPSE LICENSE AGREEMENT

By using this software, you agree to be bound by the following terms and conditions. Please note that
this contract limits our liability and that we do not provide warranties for the software. It also limits
your remedies. We encourage you to review the complete contract carefully.

General. Corpse is a package which assists in the design of orienteering courses and in the prepa-
ration of event materials such as course maps and control description sheets. It is provided free of
charge, however the Authors maintain all copyright and you may not sell Corpse or make derivative
works from it.

Intellectual Property. You acknowledge that the Author (Copyright holders) own all right, title and
interest in and to Corpse, portions thereof, or software provided through or in conjunction with Corpse,
including without limitation all Intellectual Property Rights. “Intellectual Property Rights” means any
and all rights existing from time to time under patent law, copyright law, trade secret law, trademark
law, unfair competition law, and any and all other proprietary rights, and any and all applications,
renewals, extensions and restorations thereof, now or hereafter in force and effect worldwide. You
agree not to modify, adapt, translate, prepare derivative works from, decompile, reverse engineer,
disassemble or otherwise attempt to derive source code from any part of Corpse. You agree to not
copy, duplicate or in anyway replicate Corpse User Manuals. You also agree to not remove, obscure,
or alter the Author’s or Corpse’s copyright notice, trademarks, or other proprietary rights notices
affixed to or contained within or accessed in conjunction with or through Corpse.

Changes to Terms and Conditions. The Author reserves the right to modify these Terms and
Conditions from time to time in its sole discretion, without notice or liability to you. You agree to be
bound by these Terms and Conditions, as modified. Please review the most current version of the
Terms and Conditions from time to time, located at www.o-ware.com (or such successor URL as the
Author may provide), so that you are aware of any changes.

Disclaimer of Warranties. The Author disclaims any responsibility for any harm resulting from your
use of the Corpse software and/or any third party software/libraries associated with it.

CORPSE IS PROVIDED "AS 1S," WITH NO WARRANTIES WHATSOEVER. THE AUTHOR AND
ASSOCIATES EXPRESSLY DISCLAIM TO THE FULLEST EXTENT PERMITTED BY LAW ALL EX-
PRESS, IMPLIED, AND STATUTORY WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-
INFRINGEMENT OF PROPRIETARY RIGHTS. THE AUTHOR DISCLAIMS ANY WARRANTIES RE-
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GARDING THE SECURITY, RELIABILITY, TIMELINESS, AND PERFORMANCE OF CORPSE.

YOU UNDERSTAND AND AGREE THAT YOU DOWNLOAD AND/OR USE CORSE AT YOUR OWN
DISCRETION AND RISK AND THAT YOU WILL BE SOLELY RESPONSIBLE FOR ANY DAMAGES
TO YOUR COMPUTER SYSTEM OR LOSS OF DATA THAT RESULTS FROM THE USE OF THE
SOFTWARE.

SOME STATES OR OTHER JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED
WARRANTIES, SO THE ABOVE EXCLUSIONS MAY NOT APPLY TO YOU. YOU MAY ALSO HAVE
OTHER RIGHTS THAT VARY FROM STATE TO STATE AND JURISDICTION TO JURISDICTION.

Limitation of Liability. UNDER NO CIRCUMSTANCES SHALL THE AUTHOR OR ASSOCIATES
BE LIABLE TO ANY USER ON ACCOUNT OF THAT USER’S USE OR MISUSE OF CORPSE. SUCH
LIMITATION OF LIABILITY SHALL APPLY TO PREVENT RECOVERY OF DIRECT, INDIRECT, IN-
CIDENTAL, CONSEQUENTIAL, SPECIAL, EXEMPLARY, AND PUNITIVE DAMAGES WHETHER
SUCH CLAIM IS BASED ON WARRANTY, CONTRACT, TORT (INCLUDING NEGLIGENCE), OR
OTHERWISE, (EVEN IF THE AUTHOR OR HIS ASSOCIATES HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES). SUCH LIMITATION OF LIABILITY SHALL APPLY WHETHER
THE DAMAGES ARISE FROM USE OR MISUSE OF AND RELIANCE ON CORPSE, FROM IN-
ABILITY TO USE CORPSE, OR FROM THE INTERRUPTION, SUSPENSION, OR TERMINATION
OF CORPSE. SUCH LIMITATION SHALL APPLY NOTWITHSTANDING A FAILURE OF ESSENTIAL
PURPOSE OF ANY LIMITED REMEDY AND TO THE FULLEST EXTENT PERMITTED BY LAW.

SOME STATES OR OTHER JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION
OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATIONS
AND EXCLUSIONS MAY NOT APPLY TO YOU.

Miscellaneous Provisions. These Terms and Conditions constitute the entire agreement between
the parties with respect to the subject matter hereof and supersede and replace all prior or contem-
poraneous understandings or agreements, written or oral, regarding such subject matter. Any waiver
of any provision of these Terms and Conditions will be effective only if in writing and signed by the
Author.
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Chapter 2
Overview

Features

Corpse offers the following features:

e Plan courses directly onto the map. Add a control with the click of the mouse.
Drag and drop controls into new locations. See which other courses use this
control.

e The description for any control need only be entered once. This description
will then appear in any control description for any course that makes use of
that control.

e Changes to control descriptions are automatically reflected in any control de-
scription for any course that makes use of that control.

e Control description sheets for courses can be printed in English or using IOF
symbols.

e Course lengths are automatically calculated.
e Last leg lengths are automatically calculated.

e Control description sheets can be printed in various formats, e.g. multiple
copies per page of individual descriptions for guillotining, multiple descriptions
per page for distribution with event information packages or print descriptions
straight onto the map.

e Control identification codes are checked for duplication. A cross reference
of all controls used in an event and the courses on which those controls are
used is available.

e Check control loadings, leg loadings, whether legs are being run in both di-
rections, etc.
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o Master maps and course maps can be printed. Leg lines and control circles
can be broken so as not to hide important map features. Leg lines may be
bent if required. Additional features such as logos, crossing points, water
drops, out of bounds areas and forbidden routes can be printed at the same
time.

e Courses, additional features and control descriptions can be inserted into the
EPS file created by OCAD. Courses will then be printed at the same time as
the map. Alternatively, the same Corpse data can be added to the purple
colour separation and printed as an overlay onto existing maps.

e You can produce OCAD quality maps without OCAD. Corpse cannot change
the map file or OCAD file. OCAD’s *.OCD files need never leave your protec-
tion.

e Courses can be planned on a map of one scale (e.g. 1:15000) and then
simply moved to a map of a different scale (e.g. 1:10000).

e Courses with multiple loops can be created.

e Course climbs can be automatically calculated.

What Is New In Version 4?

Corpse Version 4 has:

e Timed backup of CPE file.
e Ten level undo command.

e Approach/departure arrows are displayed around controls to aid in the place-
ment of course sequence numbers on maps.

e Control sequence numbers can be positioned in different places on different
maps for the same control.

e Control identifiers or sequence numbers can be displayed on the master map.

e A new “cartography mode” to allow maps to be marked with out of bounds
areas, forbidden routes, boundaries, water drops, etc.

e Preferences such as control circle diameter, line thickness, fonts, etc. are
now saved with the CPE file enabling the more effective sharing of files.

e Two symbols can be entered into column H.
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e Funnel Finish has been added.

e |OF symbols have been revamped. The user can even select the thickness
of the pen used to draw these symbols.

e The number of courses is now unlimited.
e The number of “holes” has been increased to 150.
e Finish circles can be broken in the same way as normal control circles.

e Corpse can leave a gap in the control circle to prevent “ink blobbing” in the
plotting process. The user can now select the size of the gap.

e Plotter registration points are now general registration points (e.g. for EPS
printing). They can now also be deleted.

e English descriptions generated by Corpse can be long (e.g. north eastern) or
short (e.g. NE).

e Controls can be used more than once on a course. This is intended mainly
for the design of multi-loop courses with a single map exchange.

e The information displayed by XRef can be copied to the clipboard.

e The “Tailor Map” function now allows for the map to be cropped to a smaller
size. This will help Corpse to run faster. The process which reduces map
colours to 256 has been enhanced to give a better colour representation of
the map.

e Titles can be optionally printed or plotted on maps to facilitate identification of
different courses.

e EPS output can be stretched to facilitate overprinting courses on preprinted
maps.

e EPS output does not use fonts to render text. This removes the need for a
font to exist on the computer equipment of the print shop.

¢ Right (click)ing over the course tabs now selects the new course before dis-
playing the Events menu.

e Controls which are not on the currently active course can be hidden providing
an uncluttered view in areas with many control sites.
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What Is New In Version 5?

Corpse Version 5 has:

e The number of D symbols has been extended to include all IOF defined sym-
bols. D symbol selectors are now grouped in blue, green, brown and black
representing their orienteering classifications.

e A new window has been added to permit you to view a course leg as the
orienteer would see it. The map is rotated so that the leg line goes from the
bottom to the top of your screen (south to north).

e A quick entry facility has been added. You can now establish courses using
a spreadsheet type entry. Basic information such as course name, number
of competitors and classes can be edited.

e View control options have been added to control the display of cartography,
control identifiers, and screen centring if a selected control is not visible.

e New Course EPS files can be produced without the need for a template file
such as the “purple.EPS” file.

e You can now create and maintain a personalised list of control identifiers
which you consider to be unacceptable, for example 161 and 191. Corpse
will warn you if you attempt to use any of these control identifiers.

e The current course length and current leg length have been added to the
status bar to facilitate course planning in “full map mode”.

e When planning courses, the use of (Ctrl)+(up arrow), (Ctrl)+(down arrow)
moves the position of the currently selected control up or down one position
within the current course. This allows you to add a new control and move it
to its correct sequence position while operating in “full map mode”.

e When planning courses, the use of (Shift)+(up arrow), (Shift)+
(down arrow), (Shift)+(left arrow) and (Shift)+(right arrow) moves the
position of the currently selected control one pixel at a time on the map in
the direction selected by the arrow.

e When planning courses, the use of (Ctrl)+(Delete) deletes the currently se-
lected control.

e Corpse can now input the “map.EPS” file generated by OCAD. You can now
select any amount of detail you wish. | have loaded maps at 900 dpi. You
no longer have to use the BMP file created by OCAD. Using the EPS file will
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ensure that you are not course planning on a BMP file which represents one
area of the map and adding courses to EPS files which represent another
area of the map.

e Corpse can now preview EPS files which have been produced by OCAD or
Corpse, and can overlay “course.EPS” files produced by Corpse onto a tem-
plate EPS map.

e Multi-loop courses can be planned as a single course. The multi-loop course
can be split into its component loops automatically.

e Relay courses can be planned as a single course. For the purposes of the
relay, any control on a course can have up to 4 alternatives. The composite re-
lay course can be automatically split into the various separate relay courses.

e A concise option has been added to the XRef facility. The information pre-
sented in the detailed XRef can also be tailored to suit your individual needs.

e Ski-O, Bike-O control format (1-32, 2-33) numbering on maps has been added.

e Courses can now have a pre-start distance (the distance from the map col-
lection point to the start triangle).

e Check marks can now be added to the master control list. This is useful when
ticking off controls which have been field checked or identifying controls which
need special attention, etc.

e Corpse data can now be exported to a text file or mailed directly.

What Is New In Version 6?

Corpse Version 6 has:

e Corpse has been updated to comply with the IOF 2004 Standard. Corpse
6 can read files created by earlier versions of Corpse but cannot write files
for use with earlier versions. This has arisen because of the fundamental
changes made by the IOF 2004 Standard.

e Course information can be exported (in the XML format) for use with other
software packages such as Sport Ident.

e The map display routines have been improved giving a much faster response
time when scrolling maps.
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e Each leg can now have a climb associated with it. These are automatically
totalled to give an overall climb for the course. Climbs for legs occurring in
multiple courses need only be entered once.

e A “display cross hairs” option has been added to control circles. This aids in
the accurate positioning of control circles on map features.

e Map markup (printing of control descriptions on maps) has been enhanced.
Control descriptions can be printed on the map fronts and/or backs.

e Qverlay printing has been added. This enables the printing of courses on
existing maps with your own printer.

e An Event Footer has been added. This can be used for general comments
such as “safety bearings” and “course closure times”.

e Corpse can now add colour text and colour pictures onto maps e.g. sponsor’s
logos.

e Blank borders can be added to the OCAD EPS file to provide off-map areas
to print control description sheets, logos, etc.

e Many other improvements such as popup menus, real-time generation of text
descriptions, user entered course length, control selector, etc.

e Direct support for plotter technology has been dropped. Plotter technology is
generally being (or been) phased out. Drivers for XP are either unavailable
or poor quality.

What Is New In Version 7?

Corpse Version 7 is the first version that is free to use.

e Increased course name length from a limit of 10 characters to a limit of 50
characters. If a course name is too wide to fit in a IOF description, the font is
automatically reduced until the name fits in the spacing requirements.

o |OF descriptions which are otherwise too long can be split across two columns,
with the position of the second column user-controlled.

e The Help File has been replaced with this reference manual (manual.pdf),
however it can still be invoked from within Corpse so that topics appropriate
to the screen currently active will be shown.
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Design Philosophy

Corpse uses an image of the orienteering map to define a working area in which
to plan the orienteering course. While the extents (length and breadth) of the map
establish the bounds of the course(s) Corpse does not alter the map in any way.
Instead, control circles and leg lines are drawn on a “film” covering the map. Corpse
also introduces the concept of “holes” in the “film”. If a leg line crosses a “hole” then
the line disappears allowing the map feature in the “hole” to be seen.

As Corpse uses the map to define the limits of the course area, then, if no map
exists there can be no courses. Furthermore, as the map is under the drawing film
then the map can be replaced by any other map or scanned image. Corpse has no
way of knowing that the image is a map let alone the right map.

Corpse maintains a “master control list” which contains the control descriptions for
all controls for a particular event. Any controls added to a course are automatically
added to the master list and are then available for use on any other courses. As
the controls in the master list are shared, any changes made to a control (position
or features) are applied to all instances in all courses. While controls are added
automatically to the master list when adding them to courses, they can only be
removed from the event by actually deleting them from the master list. A check is
first made to ensure the control is not included on any of the courses before it is
removed.

Corpse creates a single file (*.CPE) for an event. This file contains the description
of the controls, the controls in courses and their X,Y coordinates on the drawing
film. Sharing of Corpse information therefore, is achieved by sharing this CPE file.
The CPE file is typically very small and suitable for email.

The controller/setter relationship can be effectively established by initially providing
both parties with a copy of the map image. The CPE file can then be exchanged as
often as desired through the life of the course setting process.

Design Parameters

Maximum number of courses - Unlimited
Maximum number controls for an event - 255
Maximum number controls per course - 50

Maximum number of holes - 150
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Maximum number of cartographic objects - Unlimited

Corpse Files

System Files

Corpse.exe  Corpse program

Corpse.hlp  Help file

Corpse.cnt  Help file

Corpse.pch  Punch patterns as defined by the user

Temporary Files

Corpse.tmp Transient copy of current Corpse data
Corpse.bck  Timed backup of last/current Corpse data file
Corpse.00? Files created to support the Undo feature

Input files

*bmp Map images in Windows bmp format
*.eps Map images in Postscript format

Output files
*.cpe Corpse data files containing course information
"course name".eps Map images with courses in Postscript format
*.bmp Copies of bmp map images mentioned above (usually
with lower colour definition or with lower DPI) in Windows
bmp format
*.xml A self documenting XML file containing much of the data

used by Corpse for the event

System Requirements

Corpse is compatible with Windows 98, 2000, XP and Windows 7.

This reference manual has been linked to Corpse, similar to a Help File, and this
mechanism requires Adobe Reader to be installed for full funtionality. It may be

obtained free of charge from the web.

Colour printers provide better results when printing maps otherwise a black only

graphics capable printer is fine.
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Chapter 3
Getting Started

The information in this section is intended to provide a simple process for using
Corpse to plan an orienteering event and print control description sheets. There
are many more features available in Corpse which can be explored after mastering
the basic process.

House Keeping

» Create an Event Folder

Using Windows, create a folder where all files relating to this orienteering
event can be stored. While having more than one event in a folder is pos-
sible it should be avoided as Corpse creates files with default names and
may therefore overwrite or intermingle files with other event files. (For further
information, refer to the production of EPS files.)

» Acquire an Event Map

Acquire a map file by scanning a map or by exporting a BMP file or an EPS
file from OCAD. Save this file in the event folder.

A BMP file with a resolution of 200 dpi and 64000 colours provides adequate
detail.

It is better to use an EPS file if it is available. EPS files provide better qual-
ity maps and you can adjust the display quality with Corpse without having to
get another BMP file from OCAD.

» Acquire an Event EPS File

This step is only absolutely necessary if the intention is to print high quality
course maps for an orienteering event.

If your event map is an EPS file, this step can probably be skipped. If your
event map is a BMP file from OCAD then it is best to acquire the EPS file at
the same time as you acquire the BMP file so that you are certain that the
EPS file is an exact replica of the event map BMP file. Save this file in the
event folder.
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» Start Corpse
Start Corpse by (click)ing on the appropriate Windows icon.

Create An Event File

The event file contains the control descriptions, courses and other parameters for
an orienteering event. The name of these files is “filename.CPE”. A separate file is
required for each event.

A new event file is created by selecting File » New on the The default
name of the file is set to “Untitled.CPE”. Use the File » Save As option to save the
event file immediately; this has the effect of setting the default folder for all other
files.

An existing file can be opened using File » Open on the|[mnenu baror by selecting
a file from the list of up to five files displayed on the File menu on the [nenu bai

Corpse checks the structure of the event file when it opens the file. If problems
occur then, the file is reported as “corrupt”.

Name the Event

The is displayed at the top of each control sheet listing. Any combi-
nation of printable characters can be entered. Maximum length is 100 characters.
The default is “Untitled”.

The text is wrapped to fit into the available space. If the text contains a “|” then the

text is broken and a new line is commenced.

The event name is entered using Event » Event Name on the[nenu bai

Load A Map

A map is required to make use of the Corpse system. As it provides a surface on
which to place the controls, many of the tools are unavailable until a map is loaded.

Large map files will slow down the operation of Corpse. However, using maps which
are at a low[DP]|can mean that some features on the map may not be visible.
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The map is loaded using Map » Load Map on the [menu bai
BMP Map Files

Some BMP files do not have the DPI information recorded in the file. If the DPI
information cannot be found in the file by Corpse, a dialog box will appear so that it
can be entered manually.

EPS Map Files

EPS map files should be used whenever possible. The quality and size of the
resulting map is controlled by you at the time of loading. To change the quality,
simply reload the EPS file. You can also use the same EPS file in the printing
process.

£’ Load EPS File =lo =]

—tap Detail

File Hame: C:\Program FileghCorpse Bgldymap.epsz

Creator: OCAD B.00
Colours: Cyan M agenta Yellow Black.
Size: 1446 mim % 117.3 mm

—tlap Render Optian:
Colours: |1 E bit [E5,536 colours) ﬂ

DPI: 200

Memom Reqd: 1.91 mb

Okay | LCancel

It is recommended that you start with settings of 200 DPI and 16 bit colour and
experiment with other settings.

Warning The map requires the use of the physical memory of the computer
(RAM). If the map storage requirement is larger than the available RAM
then Corpse will run slowly and probably fail. It may be necessary to close
other programs to maximise the availability of your computer's RAM for
Corpse.

Set Map Scale

The map’s scale influences the calculation of course and leg lengths.
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Scale - This is the map scale, common values being 1:10,000 and 1:15,000. A
drop down list of typical values is provided. Any numeric value can be entered.

The scale is set using Map » Scale from the[nenu barl The default is 1:15,000.

Hint - Create a two control course on the map’s scale bar and compare the length
of the scale bar with the course length calculated by Corpse.

Customise View

The map is the main interface to the Corpse package.

When the map is first loaded, it is displayed at full scale. Using the
adjust the magnification to provide the largest view while still maintaining sufficient
detail to allow the placement of controls. The whole screen can be dedicated to the

map display by selecting the map mode with the M| button.

The section of the map which is displayed is controlled by using the slider bars at
the right and at the bottom of the map display.

Create Courses

The procedure outlined here requires that the control description sheet be visible
on the screen. Ensure that either the | button or £l button is down.

Repeat the following steps for each course:

e Create a new course with the desired name using Event » New Course.

e With the 2l putton down, position the cursor over the selected control site and
(click) to add a control. Controls not already on this course are also displayed
on the map. (Click)ing on an existing control will mean that it is “shared” and
not “duplicated”, e.g. the start and finish.

e Enter the control description using procedures explained at|Course Descrip-|
fions|

e Set any other information required for this course (class, course climb, com-
petitors, etc.) using the options on the Event menu.

e Drag the controls in the control list to the required position in the list to create
the desired course. (See|conirol descriptions panel).
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Note - Tools are available to remove controls from courses and reposition controls.

(See|map fools).

Multi-Loop Courses

A multi-loop course is one which requires the competitor to visit a map exchange
one or more times to obtain a map and control descriptions which describes the
next segment of the course.

Corpse enables you to plan the course as a single course using map exchange
controls where required. (See|Creaie Courses)). Because you are re-using controls
you must ensure that the control protection option is turned off. This is done through
File » Settings » Controls.

The single, multi-loop course can be split into its individual loops prior to printing of
maps or control descriptions. This is achieved with the |[Event » Separate Loops|
function.

During the split process, the first sequence number of each loop is altered so that
the numbers are identical to those of the single course. The course being split
is also replaced by one of its component loops. To retain a copy of the full course

copy it to another course prior to splitting it. This is achieved with the[Event » Copy]
[Coursel function.

When a multi-loop course is split, new course names are generated (refer to
lays). If errors are encountered, the separation process will be abandoned.

Butterfly Courses

A butterfly course is similar to a multi-loop course described above. The only differ-
ence is that the re-visited control is not a map exchange control..

A butterfly course is planned like a standard course, re-using controls as required.
(See [Create Courses). Because you are re-using controls you must ensure that
the control protection option is turned off. This is done through |File » Settings »|

To prevent Corpse from placing the control sequence numbers of the re-visited
control sites on top of each other on the map, you must use the “local control sites”
setting for this course. This is done through|[Event » Local Control Sites| You will
now be able to position the various sequence numbers for the re-visited controls
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in your preferred positions. Refer to [Setiing IOF Descriptions] Column A - Control
Number.

Relays

A relay is a course where team competitors visit one control of a cluster of controls
as opposed to all competitors visiting the same control. Control clusters are set up
so that the courses are ostensibly the same (in distance, climb and complexity) but
are not identical.

Creating Relay Courses

Relays can be planned by allocating alternative controls on a course. If, for ex-
ample, an alternate control is specified at control 2 then two relay courses will be
available. These are: Start, 1, 2, 3...., and Start, 1, 2a, 3....

To develop a relay follow the following steps:

e Develop a course in the normal way. (See [Create Courses). The controls
defined at this time are called “primary controls”. Primary controls are the
ones which appear in the control descriptions at the side of the screen. This
is called the “primary course”.

e Select a control on the primary course for which you wish to define an alter-
native control.

e With the ©I from the selected, click on a new control site with

the (Ctrl) button down. Corpse will now display the original course and the
alternative path. If a control description sheet is displayed, it will only show
details for the primary course.

e Controls can be deleted from a relay by clicking over the control to be deleted

with the 2= from theselected. If the control is an alternative control,
it will be deleted and the map updated. If the control is a primary control, it
will be deleted and replaced by one of the alternative controls (the control
description sheet will also be updated). The map will then be updated.

e Details of the various relay courses can be viewed using [XReil Alternatively,
relays can be “exploded” into the individual courses. Once a relay has been
“exploded” it cannot be “unexploded”. However, the “explode” can be undone

with the 2l button.
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e Print the courses or control description sheets as required. |f component
courses and control description sheets for relays are required then the relay
must be “exploded” first. Otherwise, only the “primary” course will be printed.
Refer to the[Event » Explode Relays|function.

Course Setting Limitations

The relay is a standard course with alternative courses. You can work on the stan-
dard course (primary course) in the normal way e.g. add controls, delete controls,
move controls on the map, etc.

Alternative courses are added to the standard course by defining alternatives for
the primary controls on the standard course. If you reposition the primary control
in the control sequence, the alternative controls are also repositioned in the control
sequence.

To modify an alternative control you will need to gain access to it; usually through
the master list. It is only there where you may enter the description, break the
control circle, or move the position of the control on the map.

Relay Course Names
The following rules apply during the “explode” process:
e The names of the “exploded” courses will be based on the original course

name with “-01”, “-02”, ... added. If the resulting names are not unique, the
“explode” process will be terminated with an error message.

e If the original course uses “local control sites” then, these positions will be
used wherever possible when placing the control identifier. Generally, for
alternative controls, the control identifier will be positioned as specified in the
master list.

Control Identification Numbers

The master control list contains all of the controls used in the event. Identification
numbers of controls can best be set using the master control list. Select the first
control in the list to have an identification number (usually not the start or finish) and

enter the first number. Use the 2 tool to allocate sequential numbers to all controls
in the master list. To establish different number runs, perform this procedure by
selecting a control anywhere in the list. Controls above the selected control will not
be renumbered.
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Control numbers on the ground can be clustered by ordering the master control list
so that controls which are near each other on the ground are near each other in the
list. Auto-numbering will result in adjacent controls having consecutive numbers.

Checking Control Utilisation

Use the [XRel|facility located on the to check information such as:

e duplication of control identifiers,

e controls that have not been provided with identifiers,
e the number of controls required,

e control loadings (especially for water drops),

e distance to the first water station on courses,

e course climbs,

e course leg lengths, and

e leg utilisation.

Print Course Descriptions

All printing is carried out using the option, available on the tool bar &l or
through File » Print. A Preview option has been provided to enable the output
to be reviewed prior to printing. It is highly recommended that a [preview]is always
done before a print.

Select the appropriate print arrangement. Typically this would be:
One per page when a single copy is required, e.g. master control list.

Many Courses per page for field checking of courses or preparation of material for
event kits.

Many Copies per page for producing multiple copies of control description sheets
for the day of the event.

Select landscape or portrait page layout. This along with font and print margins can
affect the number of control description sheets which can be printed on each page.

Corpse Version 7 — Reference Manual Page 23



Change Scale

When preparing maps for an event, it is often necessary to produce course maps
at 1:10,000 and 1:15,000. This is easily achieved by doing all of the control posi-
tioning and control descriptions at say the 1:15,000 scale. When all work has been
completed for this scale then create a 1:10,000 scale file by:

1. Save your current cpe file, e.g. “file 15000.cpe”.
2. Save your current cpe file with a different name, e.g. “file 10000.cpe”.

3. Use the stretch facility (accessed through Map » Stretch) to change the
scale from 1:15,000 to 1:10,000.

4. |Load the new map file|(which would be a 1:10,000 map).

5. Identify a control which has a position on the map which can be accurately lo-
cated e.g. on a track crossing. Use the[position all controls|facility to relocate
all controls to their correct positions.

6. Save your current cpe file, i.e. “file 10000.cpe”.

Warning The control circles will cover different areas on the map at differ-
ent scales. Check your control descriptions and circle breaks to make sure
that they are still accurate.
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Chapter 4
Settings

Use the File » Settings option to set options that are in effect each time you start
Corpse. These settings apply only to your computer. The following options are
available.

System

» Colour Match On Load

This option causes Corpse to internally change the colour depth of the map if
the map has more colours than the screen can display.

Systems such as OCAD and some scanners produce 24bit bit maps repre-
senting 16.7 million colours. If your screen is not set to display this many
colours then the computer spends significant time translating the map from
the large colour set to the smaller set.

Use Help » System Parameters to determine the colour setting for your
screen.

Warning The affect of using colour matching is that Corpse will operate
faster. The down side is that if you use a BMP file then the initial load
process for a map can be quite length. It is better to create a new BMP file
with the correct colour setting using Map » Tailor Map. If your map file is
an EPS file then the initial load process is not affected.

» Timed Backups

Setting this option will cause Corpse to periodically create a full copy of your
CPE file. The frequency at which this backup is taken is controlled by select-
ing a value for “minutes” from 1 to 1000. Backups are not taken if there have
been no changes since the last backup.

If timed backups have been selected, a clock is displayed on the bar at the
top of the map panel.
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» Punch Size

Corpse can support punches which have a size of 3x3 up to 9x9 pins. Setting
this option will cause Corpse to create new punches with the number of pins
you have selected.

» EPS Interpreter

Corpse can read EPS map files produced by OCAD. The interpretation of
these EPS files has been optimised to shorten the reading process. If prob-
lems are experienced with reading EPS files, uncheck this option.

» Control Number Window

This parameter controls the size of the flyout map segment which is used for
positioning the control identifier on the map. A segment size ranging from 10
to 50 millimetres of the map can be selected.

» Course Tabs

This parameter controls the number of characters from the course names
which are displayed on the course tabs.

Characters from the beginning or the end of the course names may be se-
lected. Setting the number of characters to 0 will mean that the whole name is
selected. Selecting a small number of characters will mean that more course
tabs will fit on the screen.

» Map Sheet Extension

Corpse uses the area defined by the map as a drawing surface for control
circles, lines, control descriptions, etc. In situations where there is insufficient
room on the map, the drawing surface available to Corpse can be extended.
This parameter controls the display colour of the additional area.

Use Map » Map Borders to adjust the size of the borders.
Note - No fill colour is used in the printing process.

Controls

» Control Protection

When this option is checked, Corpse will prevent the accidental reuse of a
control on a course.

Control reuse (of a map exchange for example) permits multi-loop courses to
be planned on a single course. This composite course can then be broken
up into the separate loops (if required) prior to printing.
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» Invalid Control Codes

This option provides you with the ability to maintain and use a list of control
identifiers which you do not wish to use, e.g. 1, 2, 3. Ticking the “Warn if
used” to warn you when one of the control identifiers listed here is about to
be used. This is only a warning and you may ignore it if you wish.

New “invalid control codes” may be entered in the edit box provided. Press
(enter) to have each new code added to the list displayed. To remove a code
from the list, select it then press (Ctrl)+(Delete).

» XRef

The XRef facility produces a cross reference listing of the controls used in this
event. It will assist in identifying unused controls, control identifier duplication
and the number of controls required for the event.

A listing of the components of the Detailed XRef enables you to tick the items
which you wish to have included in the Detailed XRef listing.

Refer to [XRefl for further information.
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Chapter 5
Preferences

Use Preferences to control the way in which Corpse generates courses and con-
trol descriptions. These preferences are stored in the CPE file with the course and
control descriptions. This means that different files can have different preferences.
Furthermore, these preferences are in effect if the file is used on any other com-
puter.

You can save and recall your own preferences using the Save as Defaults and
Load Defaults buttons. These defaults are also used when creating a new CPE
file.

Map Preferences

» Control Symbol Colours

Select the colours used to display the control circles, start triangles, finish
circles and leg lines on the map.

Selected Control - the selected control identifies the control whose charac-
teristics will be changed by (click)ing on its elements in the status bar at the
bottom of the screen.

Normal Control - controls which are included on this course. This colour is
also used for start triangles, finish circles and leg lines on the map. If the
master map is active, then all controls are normal controls.

Inactive Control - controls which are included in the master control list but
do not form a part of the currently active course.

» Map Text Font Select the font to be used when placing control numbers
on the map. You may select the font name and size of the font. Setting a
large font size may cause unpredictable results. Arial 14 point font produces
a good result.

Note - Use a common font such as “Arial” if it is intended to share files with
other computer users.
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» Hole Size Select the size (from 1.0 to 9.99 millimetres) at which holes will be
placed on the map for the purposes of breaking leg lines.

» Control Symbol Size Select the size at which control circles are drawn on
the map. A circle size of 6 mm produces a good result.

» Sequence Number Format Select the format to be used when drawing
the sequence numbers on the map. Selecting 1 will result in consecutive
numbers; selecting 1-300 will cause the control identifier to be printed after
the normal sequence number

» Leg Line Clearance The leg line clearance is the amount of space left be-
tween the control circle and the end of the leg line when rendering courses
on maps. Select the size of the gap required.

» Control Line Thickness Select the width (from 0.1 to 0.99 millimetres) to be
used when drawing control circles and leg lines on the map. A line thickness
of 0.35 mm produces a good result.

IOF Control Descriptions

» Sheet Line Thickness Select the width (from 0.1 to 0.99 millimetres) at
which lines are drawn when producing the boxes on IOF control descriptions.

Note - IOF control description boxes have been sized at the centre of the
lines which form the boxes. If thick lines are used printing will encroach into
the page margins. If the left page margin is set to zero the vertical box lines
on the left may appear to be half as thick as the other lines. This is because
half the line thickness occurs in an area in which the printer cannot print.

» IOF Sheet Lines All IOF sheet lines are drawn with the “normal” thickness
specified above.

Checking “heavy outside line” will cause the outside line of the IOF descrip-
tions to be drawn with the “heavy” line thickness specified above.

Checking “heavy third line” will cause the horizontal line after every third con-
trol description of the IOF control descriptions to be drawn with the “heavy”
line thickness specified above.

Check the desired column boxes to produce a “heavy” line after the selected
box or boxes on the IOF control description sheet.

» IOF Sheet Cell Size Select the size of the boxes used on the IOF control
description sheet.
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» Font Select the font to be used when placing text such as control numbers
on the IOF control description sheets. You may select the font name and size
of the font. Setting a large font size may cause unpredictable results.

Note - Use a common font such as “Arial” if it is intended to share files with
other computer users.

» IOF Symbol Pen Width Corpse renders IOF symbols by drawing straight
lines and curves. This option allows you to select the width of the pen used
in the drawing process. Select a value (from 0.1 to 0.99 millimetres) which
provides you with the best result for the printing process.

English Control Descriptions

» Sheet Width

Select the width in millimetres available to print English control description
sheets. Setting this number to less than 50 millimetres or setting a large font
size may cause unpredictable results. The minimum value accepted is 30
millimetres.

» Font

Select the font to be used when placing text on English control description
sheets. You may select the font name and size of the font. Setting a large
font size may cause unpredictable results.

Note - Use a common font such as “Arial” if it is intended to share files with
other computer users.

This font is also used for the printing of other English (text) based reports
such as XRef, Control Codes and Punch Patterns, as well as for rendering
map titles.

» Descriptions

You can elect to have Corpse generate English descriptions in long (e.g.
north eastern) or short (e.g. NE) format. To put this option into effect you
have to re-generate the English descriptions.

You can elect to have Corpse generate a new English description for a control
each time the IOF description is changed. If this option is selected, any user
entered text is automatically replaced by Corpse. If this option is not selected
then a new English description is entered by the processes outlined at[Sefiing]
[English Descriptions]
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Chapter 6
Screen Components
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File Menu

Use the File menu to open, save, and print new or existing event course descriptions

and maps.

The commands on the File menu are:

New

Open
Save
Save As

Export

Mail To

Settings

Models

Print Setup

Print
Exit

History List

Creates a new event file. The file is either new (no courses) or
one of the model events previously defined.

Loads an existing event file.
Saves the current event using its current name.
Saves the current event using a new name.

Creates a text file with much of the information for the current
event. The format of this file is self documenting.

Generates an E-mail with a copy of the current event file (*.CPE)
attached.

Sets parameters that affect the operation of Corpse, e.g. timed
backups.

A model is a new event with a selected set of course tabs already
created. This option enables the creation of a new model using
the course tabs defined for this event. No other information is
saved, only the course names.

Enable the selection of a printer and the setting of its characteris-
tics.

Opens the Corpse Print Manager.
Closes the open event file and exits the Corpse program.

Lists the last five events you have closed.
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View Menu

The View Menu permits you to control the way Corpse displays the information on
the screen.

The map provides the working surface on which to place controls. Until a map is
selected, many Corpse functions are not available. The map can be changed at
any time, however, if a smaller map is chosen, already defined controls may no
longer be accessible as they are no longer on the map.

| 2

>

Map Only
Refer to[\lode lools

Map and IOF
Refer to

Map and English
Refer to[Mlode Toolsl

Cartography
Refer to

Control Focus

When a control is selected, via the Control Descriptions Panel for example,
Corpse will ensure that the control can be seen on the computer’'s screen
by moving the focus (view window) of the map. This will also occur when
changing view from one course to another. This option can be de-selected to
prevent this refocusing from occurring.

Runner’s View
Selecting this option causes the [Runner’s View|window to be displayed.

Refresh
Refreshes the display.

Hide Cartography

items take time to draw on the screen. Selecting this option will
prevent Corpse from displaying these objects on the map unless Corpse is in

Cartography mode. Setting this option has no affect on the printed result.

Corpse Version 7 — Reference Manual Page 33



» Hide Control Numbers

Selecting this option will prevent Corpse from displaying control identifiers or
sequence numbers. This means that important map detail will not be ob-
scured by these numbers. This can be a problem on the master map which
may have many controls in a confined area.

» Hide Inactive

Selecting this option will prevent Corpse from displaying controls which do
not belong to the course currently being displayed. This means that important
map detail will not be obscured by these controls. However, controls which
are not currently visible can still be added to the current course by (click)ing

over the location of the hidden control with the o button down.

» Quick Scroll

When the map image is scrolled using the vertical and horizontal slider bars,
the course is drawn on the newly exposed section of map. This drawing pro-
cess may slow down the scrolling process. Selecting this option will prevent
the course from being redrawn until the mouse is released at the end of the
scrolling process.

Note - Quick scroll is always selected when in Cartography mode.

» Cross Hairs

When Cross Hairs is selected, Corpse will display a fine line “+” depicting the
centre of the control circle. Cross hairs in conjunction with[speed keys|can be
used for accurate positioning of control circles.

Map Menu

The map provides the working surface to place controls. Until a map is selected,
many Corpse functions are not available. The map can be changed at any time,
however, if a smaller map is chosen, already defined controls may no longer be
accessible as they are no longer on the map.

» Load Map

A dialog box is provided to select a Windows BMP file or an EPS file repre-
senting the orienteering map. The BMP file can be sourced from your scanner
or from OCAD. The software which loads the EPS file is specifically designed

for EPS files generated by OCAD. Refer to [Corpse, OCAD and EPS|for fur-
ther information.
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Some BMP files do not have the [DF] information recorded in the file. If the
DPI information cannot be found in the map file, a dialog box will appear so
that it can be entered manually. Corpse will automatically compensate for
changes in DPI. This means that for large maps, a file with low resolution
can be used for the preliminary work; this will provide better responsiveness
from the computer. A map with higher resolution can then be used for any
necessary fine tuning in positioning controls or printing maps.

Warning When the map is loaded, Corpse checks to ensure that any ex-
isting controls still fit on the map and provides you with the opportunity to
delete controls which no longer fit on the map.

» Map Scale

The map’s scale influences the calculation of course lengths. Typical orien-
teering map scales being 1:10,000 and 1:15,000. A drop down list of typical
values is provided. Any numeric value can be entered.

Hint - Create a two control course on the map’s scale bar and compare the
length of the scale bar with the course length calculated by Corpse.

» Stretch

This option permits the courses which have already been entered into Corpse
to be overlayed onto a map of a different scale.

Suppose a map of 1:15,000 has been used for course setting and that all
courses except the Blue course are to be printed on a 1:15,000 map. The
Blue course is to be printed on a 1:10,000 map. Prior to printing the Blue
course, Stretch should be used to tell Corpse that the map’s scale is to be
changed from 1:1,15000 to 1:10,000. A new BMP or EPS file should be
loaded to ensure the control locations are correct (the different maps may not
cover the exact same areas or may be positioned differently on the printed
page). Refer to [Miap Tools » Select|to see how to move all controls in a
single action.

It is best to save the Corpse event file to another file before undertaking this
operation to avoid confusion.

» Map Borders

Corpse uses the area defined by the map as a drawing surface for control
circles, lines, control descriptions, etc. In situations where there is insufficient
room on the map, the drawing surface available to Corpse can be extended.

Selecting this option will present a dialog box for you to add borders to the
map. Borders may be altered at any time; Corpse will automatically reposition
control locations etc if the left or top border is changed. However, items for
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which you have entered the position from the top left corner of the map are
not moved. These items include the position of the control descriptions on
printed maps.

The colour used to display the map borders is set with [System » Settings|
No fill colour is used in the printing process.

» Map File Info
This option displays information about the currently selected map file.

» Tailor Map

The tailor map function is provided for altering the colour depth, size and
resolution of a BMP based map. To alter these parameters for an EPS based
map, re-load the EPS file and select the new parameters required.

The BMP file produced by OCAD or a scanner can make the operation of
Corpse quite slow. This may arise from the DPI of the BMP file being too high
or colours in the BMP file being far greater than can be viewed on the screen
of your PC.

This tailor map function presents you with two images of your BMP file. The
left most image is the original while the right most image shows you what will
happen if the changes you have selected are implemented.

You may:

Reduce the DPI of the map

Reduce the number of colours in the map (increasing the number of
colours does not have that affect; it simply slows Corpse by using more
memory)

Remove any white border on the map (crop)

Select an area (window) of the map which is large enough for the courses
you are setting

A new BMP file with new characteristics can be created and saved. This
new BMP file can be used interchangeably with the BMP file from which it
was created. Corpse automatically compensates for variations in the DPI
between files. However, if you crop the map on the left or the top then all
controls will have to be repositioned

Event Menu

The Event menu can be accessed from Event on the[menu barjor by (click)ing the
right mouse button when the cursor is over the course tabs at the bottom of the
screen.
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The event menu provides access to the following functions (which generally apply
to the currently selected course):

» Event Name

Selecting this function will provide you with a menu to enter the name of the
“orienteering event”. The name of the event is limited to 100 characters. If the
text contains a “|” then a new line will be forced at that position. Care should
be taken such that this name will be printed clearly on the control descriptions
sheets.

» Event Footer

Selecting this function will provide you with a menu to text which will appear at
the bottom of each control descriptions sheet e.g. a safety bearing, or course
closing time. The footer is limited to 100 characters. If the text contains a “|”
then a new line will be forced at that position. Care should be taken such that
this name will be printed clearly on the control descriptions sheets.

» New Course

Selecting this function will create a new course and provide you with a menu
to enter the name of that course. The name of the course is limited to 50
characters and must be unique. Care should be taken such that this name
will be printed clearly on the control description sheets. Selection of a large
font may result in this name being clipped when control description sheets
are printed.

» Delete Course

Selecting this function will enable you to delete the course currently showing.
The controls used by this course are not affected and remain in the master
control list.

Note - The master control list cannot be deleted.

» Rename Course

Selecting this function will enable you to change the name of the currently
selected course according to the same constraints applying when creating
the course.

Note! The master control list cannot be renamed.

» Copy Course

Selecting this function will enable you to copy the control descriptions from
another course to the current course. Any existing information in the current
course will be overwritten. To duplicate a course, create a new course and
then copy the course to be duplicated.
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This option is disabled if there are no other courses available.
Note! The master control list cannot be copied from or to.

» Explode Relays

This function is available if the current course is a Relay. Selecting this func-
tion will cause the current relay course to be replaced by all of the courses
which make up the relay. It is wise to create a backup copy of your cpe file
before using this function.

» Separate Loops

This function is available if the current course is a Multi-Loop course. Select-
ing this function will cause the current course to be replaced by a separate
course for each loop. It is wise to create a backup copy of your cpe file before
using this function.

» Climb

Selecting this function will enable you to enter up to eight characters to de-
scribe the course climb of the currently selected course. To get Corpse to
calculate the course climb from the leg climbs you have entered, use a "#”
for climb in metres or a “%” for climb as a percentage of the course length.

This option is disabled when the master control list is selected.

» Classes

Selecting this function will enable you to enter up to 100 characters to de-
scribe the competitor classes for the currently selected course. If this field
is left blank then this area is omitted from the display or printing of control
description sheets. If the text contains a “|” then a new line will be forced at
that position.

This option is disabled when the master control list is selected.

» Competitors

Selecting this function will enable you to enter the number of competitors for
the currently selected course.

This option is disabled when the master control list is selected.

» First Sequence Number

Selecting this function will enable you to enter the sequence number of the
first control of a course. This provides the capability to generate multi-loop
courses and still maintain a consecutive sequence of control numbers from
one course to the next.

This option is disabled when the master control list is selected.
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» Map Markup
The Map Markup facility provides you with control over the way your maps
are prepared for printing. Refer to[Vlap Markup]

» Local Control Sites

If this option is selected, the position of control sequence numbers on the
map are unique to this course. The initial positions will be copied from the
positions specified for the master control map.

If this option is not selected, the position of control sequence numbers on the
map are those specified for the master control map.

Warning Shifting a sequence number on any course which does not use
local control sites will affect the master and any other course which does
not use local control sites.

This option is disabled when the master control list is selected.

» Display Control IDs

If this option is selected, the numbers displayed on the screen are the control
identification numbers. If not selected the sequence number in the list of
controls is displayed.

This option is only available for the master control map.

» Order Controls

(Click)ing this option will cause the controls in the master control list to be
sorted in order of the control identifier. The order is start, finish, numeric,
alphanumeric and leg bends. Each group is in ascending order.

This option is only available for the master control map.

Quick Entry

The Quick facility provides you with the ability to create, delete and order courses
using a spreadsheet format. Only the basic information such as course name,
classes, climb and competitors can be added. Fields in the spreadsheet can be
copied using the standard Windows functions of (Ctrl)+(C) and (Ctrl)+(V). Data
can be entered into a cell by moving to the cell and start typing. If you press (Enter)
the contents of the cell will be selected and you will be ready to edit the information
already in the cell. Press (Enter) to complete the edit operation or (Esc) to abort
the operation.
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» Add Course
Use the Edit menu or (Ctrl)+(Ins) to create a new course. The course is
inserted after the currently selected course.

» Delete Course
Use the Edit menu or (Ctrl)+(Del) to delete the currently selected course.

» Move Course

Courses can be moved to a different position in the list by dragging them to
a new position with the mouse. A course can also be moved one position up
or down by using the Edit menu commands or (Ctrl)+(U) or (Ctrl)+(D).

Preferences

Use Preferences to control the way in which Corpse generates courses and con-
trol descriptions. These preferences are stored in the CPE file with the course and
control descriptions. This means that different files can have different preferences.
Furthermore, these preferences are in effect if the file is used on any other com-
puter.

Choose one of the following options:

[Map]

[[OF Control Descriptions|

[English Control Descriptions|

You can save and recall your own preferences using the Save as Defaults and
Load Defaults buttons. These defaults are also used when creating a new CPE
file.

XRef Menu

The XRef facility produces a cross reference listing of the controls used in this
event. It will assist in identifying unused controls, control identifier duplication and
the number of controls required for the event.

It should be noted that the usage of individual controls can also be viewed by
(Click)ing the right mouse button while the mouse is over a control in the map
panel. This will display a list of courses using the particular control.
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If the event contains relays, the relays will be “exploded” into their component
courses prior to XRef generating its information. If there is a problem exploding
the courses, XRef will terminate and no information will be generated. Refer to

[Relays|for more information.

» Concise
Concise XRef lists course name, course length, number of controls, competi-
tors and classes in a tabular form.

» Detailed
Information produced by Detailed XRef includes:

— Event statistics (control requirements, unused controls, number of courses
and total number of competitors).

— Course statistics (number of competitors, competitor class, controls on
course, distance to water and, maximum, minimum and average leg
lengths).

— Control utilisation (number of competitors to visit a control and which
courses use the control).

— Leg utilisation (number of competitors to use a path between two partic-
ular controls and which direction they will run).

The volume of information displayed is controlled by [File » Settings|

The XRef information can be copied to your computer’s Clipboard by pressing
(Ctrl)+(C).

Utilities Menu

The Utilities menu provides access to:

» Off Map

This utility enables the removal of controls which no longer fit within the
bounds of the map. This can occur if the map file is replaced by a smaller file
or is re-scaled.

» Clear Holes

This utility removes allholes|which may have been added to the event file.
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» Clear Cartography

This utility removes all [cariographic objecis| which may have been added to
the event file.

» Clear Checked
This utility removes all of the check marks from the control descriptions.

» Load Punch Patterns
If the Punch Pattern file has been altered, this utility updates the punch pat-
terns for the controls in this event.

» Sort Courses Ascending
This utility rearranges the course tabs (excluding Master) into ascending al-
phabetical order from left to right.

» Sort Courses Descending
This utility rearranges the course tabs (excluding Master) into descending
alphabetical order from left to right.

» Punch Patterns
This utility enables the creation and editing of a punch pattern file. Refer to
Punch Patierns|for further information.

» EPS Viewer
Corpse has a facility for viewing EPS files. You can view a base EPS map and

can also overlay course maps onto the base map. Refer to
[2nd EPS]for further information.

Help Menu

The Help menu provides access to:

» Contents
This item displays the Help Topics dialog box to enable you to quickly navigate
through specific areas of Help.

» System Parameters
The system parameters provide information about:

Maximum number of courses - The maximum number of courses (not in-
cluding the master control list) which can be managed in a Corpse event file.
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Maximum number of controls for an event - The maximum number of
control descriptions which can be held in the master control list.

Maximum number of controls per course - The maximum number of con-
trols which can be held in any course description list.

Maximum number of map holes - The maximum number of holes which
can be placed over the map for the purpose of ensuring that leg lines do not
hide features on the map.

Map colours - The number of colours possible in your current map.

Map storage - The memory in kilobytes used to store your current map image
whether or not it is a BMP file or an EPS file.

Map DPI - The resolution of your current map image whether or not it is a
BMP file or an EPS file.

Map size - The size of your current map (width x breadth) in millimetres.

Screen resolution - The number of dots in the horizontal and vertical di-
rections on the screen. The resolution is determined by the installed screen
driver and is set by Windows.

Screen colours - The number of colours supported by your screen driver
and screen.

Physical memory - The size of the computer’s physical memory (RAM) in
megabytes.

Swap file size - The disk space in kilobytes used by Windows to support the
programs currently running.

Available space on drive - The available disk space in kilobytes on the drive
where Corpse is installed.

» About
This item provides access to program information such as release number
and release date.

» Corpse Home Page

A direct link to the Corpse web page where you can find out more about the
latest version of Corpse.

Tool Bar
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File Management Tools

EﬁlE'PlElll

The tools in this group are shortcuts to functions contained on the and
include:

New file

Open file

Save File

Print

Map Tools

Ofx ool @]

The tools in this group affect the operation of the mouse when it is over the map
panel. These buttons are mutually exclusive with one and only one button being
selected at any one time.

A button is selected by (click)ing it. While the mouse is over the map image, right
(click)ing will cause the Ol button to be selected if it is currently not selected. If the
Ol button is already selected, then the Select button will be selected.

2| control

When this button is down, the cursor will change to crosshairs with a circle
when it is over the map. The effect from (click)ing while the cursor is over the
map depends on the following:

The master control map is showing. (Click)ing on any area on the map
that does not have a control marked will cause a control to be placed on the
map and an entry added to the master control list. Controls cannot be placed
directly on top of each other.

A course map is showing. (Click)ing on any area on the map that does not
have a control marked will cause a control to be placed on the map and an
entry added to the master control list. (Click)ing on top of an existing control
which is not already part of the current course will cause this control to be
added to the end of the course.
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The new control will become the active control.

Controls can be placed with their centres at a distance of one eighth of the
diameter of the control circle. To create close controls it may be necessary to
create the second control clear of any existing controls and then drag it into
position or move it using keyboard controls.

x| select

When this button is down, the cursor will change to an arrow when it is over
the map. Four actions are possible in this mode.

Select Control. (Click)ing on top of a control on this course will cause it to
become the active control. The colour of the control on the map will change
to reflect this. The control will be highlighted in the control description panel
if it is displayed. The control description will be displayed in the status bar at
the bottom of the screen.

Position Control. If the left mouse button is held down while the cursor is
over a control on the current course then that control can be dragged off to a
new location on the map. The drag action is started when the cursor changes
to directional crosshairs. The drag action is stopped when the mouse button
is released. The dragged control will also become the active control.

Position All Controls. If (Ctrl) is held down before the “position control”
action is started then all controls will be moved.

Control Usage. The usage of individual controls can be viewed by holding
down the right mouse button while the mouse is over a control in the map
panel. This will display a list of courses using the particular control. The list
disappears when the right mouse button is released. The list does not display
the name of the current course. If the box displayed is empty then the control
is only used on the currently displayed course.

| cut

When this button is down, the cursor will change to a pair of scissors when it
is over the map. Two actions are possible in this mode.

Delete Course Control. (Click)ing on top of a control on this course will
cause it to be removed from the course.

Delete Event Control. Controls can only be removed altogether if the delete
function is carried out on the master control map. If the control is in use on
any other courses it cannot be deleted unless it is first deleted from the other
courses.

| Break

When this button is down the cursor, will change to crosshairs with a broken
circle when it is over the map. (Click)ing with the crosshairs on the line
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of a control circle will cause a segment of the control circle to appear or
disappear. The double finish circle can also be broken but you must (click)
over an imaginary circle midway between the double circles. Both circles will
be broken.

This feature can be used to prevent control circles from hiding important fea-
tures on the map. The control circle has been defined to have 16 segments
which can be turned on or off individually. It is possible to turn off all 16
segments; this will make it difficult to select the control later on.

2| Holes

When this button is down the cursor, will change to crosshairs with a hole
symbol when it is over the map. Any holes which have already been defined
will also become visible.

(Click)ing over the map area will cause a hole to appear at the crosshairs.
Holes can be removed by (Ctrl)+(Click)ing with the crosshairs over a hole.
Holes cannot be moved. They must be deleted and redefined. There is no
restriction with the placement of holes. They can be placed directly on top of
each other (causing some confusion when trying to delete a hole) or they can
be overlapped to form an elongated effect.

Holes should be added when nearing completion of course setting as a large
number of holes may slow down the operation of Corpse. It should be re-
membered that holes only affect leg lines; control circles, triangles and text
are not affected by holes.

Window

When this button is down, (click)ing and holding the mouse button down will
start drawing a rectangle on the map. The rectangle will be complete when
the mouse button is released. The rectangle drawn can be resized or moved
as required; the cursor changes to show the possible action when over the
window or the lines which delineate the window.

This rectangle denotes the window of the map which can be printed if desired.
The rectangle disappears when the (Window) button is up and will reappear
the next time it is down.

*4 Print Registration

When this button is down the cursor, will change to crosshairs with two “+”
signs. This enables you to identify two printing registration points. These will
aid in ensuring that Corpse course prints are positioned correctly on the map.
Registration points are optional unless courses are being overlayed.

Registration Point 1 - Locate the crosshairs at the desired point, then with
the (Ctrl) button pressed (click) the left mouse button. A “+” will appear on
the map.
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Registration Point 2 - Locate the crosshairs at the desired point, then with
the (Alt) button pressed (click) the left mouse button. A “+” will appear on

the map.

To redefine either of the registration points, execute the appropriate step de-
fined above.

To remove the registration points, with both the (Ctrl) and (Alt) button pressed,
(click) the left mouse button anywhere over the map.

Zoom Tools

zlEN

o
o°|

The tools in this group affect the magnification of the map display. The current
magnification is displayed on the status bar at the bottom of the screen.

Bl

Zoom to fit

(Click)ing this button changes the view magnification so that the entire map
is displayed on the screen. A magnification of less than 25% can occur de-
pending on the size of the map.

Zoom out

Each time this button is (click)ed the map is moved further away. The current
magnification is reduced by 25% of full size. The minimum magnification is
25%.

Full scale

(Click)ing this button causes the map to be displayed at the size at which it
was scanned (100%).

Zoom in

Each time this button is (click)ed the map is moved closer in. The current
magnification is increased by 25% of full size. No upper limit has been set on
the magnification.

Zoom to Course

(Click)ing this button causes the map to be displayed at the size at which it
all controls of the current course will just fit in the map display window.
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Mode Tools

Wl Elel

The tools in this group affect the display. These buttons are mutually exclusive with
one and only one button being selected at any one time.

MM

The screen displays only the map.

Al

The screen displays the map and the corresponding control descriptions in
IOF symbol notation.

ElE

The screen displays the map and the corresponding control descriptions in
English notation.

clc
The screen displays the map and a set of cartographic tools. These tools

allow features such as crossings, out of bounds, water drops, etc. to be
placed on the map. Many of the other tools are disabled when in this mode.

Miscellaneous Tools

Auto Number
This tool is only active when the master control list is displayed.

This tool numbers control identifiers in the following way. Working in the
master control list, the first standard control (i.e. not a start or finish control)
is located; the search commences from the currently selected control. If the
control identifier is numeric then all subsequent standard controls receive a
sequential number based on the first standard control.

Auto Words

This tool generates English descriptions from the IOF descriptors for the con-
trol. The English descriptions for ALL controls will be replaced. Any person-
alised editing will have to be re-performed.
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L| Delete Unused Controls

This tool removes any controls which are included in the master control list
but not used in any course descriptions. The listing of these controls can be
viewed with

Unused controls can be removed from the master control list using the normal

El Show All Courses

When this tool is depressed, it shows all courses on the current map. This
provides an overview of the utilisation of a control site and the various arrival
and departure legs for a control.

ﬁ' Hide Inactive Controls

When this tool is down inactive controls (i.e. controls not on this course) are
not displayed. The controls are still there and Corpse reacts accordingly. This
mode provides a clear view of surrounding features which might otherwise be
hidden by inactive controls.

E' Runner’s View

When this tool is down a floating, resizeable window is displayed. The window
contains an image of the map as the runner would probably hold it. The
current control is displayed at the bottom of the window. The next control is
displayed at the top of the window. The map is rotated such that the leg line
is orientated in a south to north direction with north at the top of the screen.

If the runner is at the last control, the window is black indicating the end of
the course.

The field of vision of the runner can be altered by dragging the sides of the
window left or right. However, the larger the map segment is the more the
processing power that is required to rotate the map. The window may also be
moved to any position on the screen.

When the Runner’s View window is displayed it is displayed at its last used
position. Holding down the (Ctrl) button when activating the Runner’s View
window will display the window at the top left of the screen. This will enable
the recovery of the window if it fails to appear on screen when it is supposed
to.

E' Undo

Corpse supports 10 levels of undo to allow changes to be backed out. When
the mouse is placed over the undo button a message is displayed identify-
ing the nature of the change which will be backed out should the button be
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pressed. In backing out the change Corpse returns itself to the state it was in
just prior to the change being backed out.

Map Panel

The map panel displays the map currently loaded. The top bar of the map panel
displays the name and the scale of the map.

A new map can be loaded at any time. The scale can also be changed at will.
Changing either of these can affect course length calculations or result in controls
that cannot be accessed as they do not fit within the bounds of the new map.

The appearance of a clock on the top bar indicates that[iimed backups|of the event
file will be taken.

Control Descriptions Panel

The Control Descriptions Panel, when visible, appears at the right hand side of the
screen. Corpse can be set to display control descriptions in either English or IOF
notation. See

The Control Descriptions Panel shows the control descriptions and the order of
controls on a course.

The order in which controls appear in the control descriptions can be changed by
(click)ing over a particular control description and, with the mouse button down,
drag the control up or down to its new position. Information on the control descrip-
tions sheet such as course length, distance to finish control, and control sequence
number are all automatically adjusted. The course is also redrawn on the map
showing the control in its new sequence position.

Status Bar

The status bar is located above the course tab set at the bottom of the screen and
contains the following displays:

IBDuIder

When control features are being selected, this window will display an English de-
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scription of the feature currently under the cursor. In this case a “boulder” control
site is being selected.

%

This enables you to add check marks to controls. This is useful when ticking off
controls which have been checked or identifying controls which need special atten-
tion, etc. Check marks are printed on the master control list. Checked controls are
displayed with a grey background in control description sheets. Checked controls
are not reflected in any way in course control descriptions.

|+ ftos/— &| P3O Essternbouider, 3.00.5m, south east side |

This display shows the complete description (IOF symbols and words) of the control
currently selected on the course show in the map panel. This display is “live” and is
used to establish or change control features. See [Setting |OF Descriptions]

This display shows the current magnification of the map displayed in the map panel.
A new view scale can be selected by (Click)ing the right mouse button over this
display.

E4E 235

This display shows the current position (X,Y) of the mouse over the map image.
The X and Y values are expressed in millimetres from the top left hand corner of
the map image.

783

This display shows the current leg length in metres. The distance is from the high-
lighted control (or leg bend) to the previous control. The previous control may be the
course start. If a distance is displayed for the first control then this is the pre-start
distance.

4.6 km

This display shows the current course length in kilometres. The distance also in-
cludes any pre-start distance.
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Course Tabs

:I"' ;Master:f-,CDursm jCourse? /
==

The course tabs identify the courses currently defined for this event. Selecting
one of the available tabs will make that course active and display both the relevant
course on the map and control descriptions sheet. The active control in the status
bar will also be changed. The map screen will be scrolled to bring the active control
into view.

When there are more tabs than will fit across the bottom of the screen, two arrows
will appear at the right hand side to scroll the tabs to provide access to the tabs not
currently visible.

To add or delete courses, or modify information such as course name, use the
Alternatively, a right (click) over a tab on the Course Tabs bar will
produce an Event pop up menu. This will allow you to change information for the
currently selected course.

(Click)ing either of the two arrows at the left hand end of the course tabs will move
the currently selected tab one position to the left or right. The Master tab cannot be
moved.

The (Page Up) and (Page Down) keys will allow you to select the tab to the right
or to the left of the currently selected tab.
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Chapter 7
Map Markup

The Map Markup facility provides you with control over the way your maps are
prepared for printing. You can decide whether maps have IOF or text based control
description sheets on the front of the map, where the descriptions are positioned
and whether they are overprinted or whether the area behind the control description
is blanked out first.

The markup for each course can be based on the markup of the Master map. For
example, if all maps are to have IOF descriptions in the top right hand corner then
these options should be selected for the Master. All of the other courses should
then identify “Use Master”. If one or two of the other courses require something
different then turn off the “Use Master” and set the specific requirements for that
course.

When producing EPS files as output, you have the option to specify printing control
descriptions on the back of the map. Corpse produces a new file which has the
same dimensions as the map. This is a blank sheet with the specified markup. As
a result you can have control descriptions printed on both the front and the back of
the map. You may even have IOF on the front and text on the back.

General

» Overlay Printing

If checked, material is printed on to the map without first clearing the map
image behind.

Front of Map

» Titles

Text - Any printable text up to 50 characters in length. If you include a “|” then
a new line will be forced at this position. If you include “%e” then the current
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Event Name will be substituted. If you include “%c” then the current Course
Name will be substituted.

Position - The distance in millimetres (X,Y) from the top left corner of the
map sheet. The default position is 0,0. If the map borders are changed, this
Position will have to be changed to cater for the new borders.

» Control Descriptions
Type - Choose from one of None, IOF, English descriptions on the map.

Position - The distance in millimetres (X,Y) from the top left corner of the
map sheet. The default position is directly below the position of the titles plus
a vertical gap equal to the Gutter setting in Print Options. Care must be taken
to ensure that the control descriptions to be printed will fit on the printed map.
Furthermore, if the map borders are changed, this Position will have to be
changed to cater for the new borders.

» Logo

Position - The distance in millimetres (X,Y) from the top left corner of the
map sheet. The default position is directly below the position of the control
descriptions plus a vertical gap equal to the Gutter setting in Print Options. If
the map borders are changed, this Position will have to be changed to cater
for the new borders.

Back of Map

» Control Descriptions
Type - Choose from one of None, IOF, English descriptions on the map.

Position - The distance in millimetres (X,Y) from the top left corner of the
map sheet. The default position is 0,0. Care must be taken to ensure that
the control descriptions to be printed will fit on the printed map back. Further-
more, if the map borders are changed, this Position will have to be changed
to cater for the new borders.
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Chapter 8
Course Descriptions

Setting IOF Descriptions

ABCDETFG
[+ ftos/— &[ PEJC[  Essternbouider, 3.00.5m, south east sice [*|

» Column A - Control Number

The first control number (its sequence number) on a course defaults to 1. This
can be changed to accommodate multi-loop courses - refer to [Event » Firsi|
[Sequence Number] on the The second and subsequent control
numbers are automatically generated and cannot be changed in indepen-
dently.

The default position on the map where the number is placed is the centre of
the control circle. The control number position can be altered so as to avoid
confusion with nearby controls or course lines, or such that it does not hide
important map detail.

(Click) and hold over the control sequence number box to activate a flyout
map segment. The map segment will also display arrows indicating the ap-
proach and departure directions of the various courses which use this control.
The position of the control number can be moved anywhere inside the flyout
box. Move the cursor to the desired position and release the mouse button.
The control number will then be automatically repositioned on the map.

The size of the flyout map segment is controlled through the options
under File » Settings.

Warning If the currently active course uses “local control sites” the new
control number position will only apply to the current course. Otherwise,
the new position will apply to this course, the master and all other courses
which do not use “local control sites”.

[Local Control Sites|option.
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» Column B - Control Code

When a control is first placed on the map, it is an unnumbered control site. It
can be changed to a start triangle or finish control, or be given a control code.
It can also signify a taped route or leg bend.

(Click) and hold over the control code box to activate a flyout menu which
offers a choice of control types. Move the cursor to the desired control type
and release the mouse button. The control symbol will then be automatically
redrawn on the map to reflect your choice.

The control types available are:

O
@

Normal control - depicted by a circle on the map.

Taped control - depicted by a circle on the map. This is a normal con-
trol but also indicates that the route from the previous control is taped.
An extra line of text containing “Follow tapes to next control” is automat-
ically added to the English control descriptions sheet between the two
controls.

Start triangle - depicted by a triangle on the map. On course maps the
triangle is rotated to point in the direction of the next control. On the
master map the triangle is orientated north south. When the start trian-
gle option is selected, a dialog box will appear to enter a “pre-start dis-
tance” in metres from the start area to the start triangle. After a pre-start
distance is entered, the course length will then contain this distance.

Map Exchange - depicted by a triangle on the map. On course maps
the triangle is rotated to point in the direction of the next control. On
the master map the triangle is orientated north south. The leg line ap-
proaching this control is dashed to indicate that the route is taped.

Finish control - depicted by a double circle on the map. The approach
to this control is not taped and requires the orienteer to navigate to it.

Taped Finish - depicted by a double circle on the map. The leg line
approaching this control is dashed to indicate that the route is taped.

Funnel Finish - is depicted by a double circle on the map. The approach
to this control is not taped and requires the orienteer to navigate to the
funnel tapes.

Follow tapes - control is depicted on the screen map as a dashed cir-
cle. The dashed circle is not printed on course maps but is printed on
the master map. The course leg from the previous control is dashed
indicating “follow tapes # metres away from the previous control”.

Leg bend - depicted on the screen map as a small circle. The circles
do not appear on printed maps. Leg bends enable you to change a leg
line from a straight line to one with bends. The bend does not affect the
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leg line type (dashed or solid) but does affect the leg length. A number
of leg bends can be placed between any two controls.

Mandatory Crossing - depicted on the screen map as a small circle.
The Mandatory Crossing is the same as a Leg Bend with the additional
function that it places a Mandatory Crossing description in the control
description sheet.

If a crossing symbol is required on the map then this is done in cartog-
raphy mode.

Mandatory Passage - depicted on the screen map as a small circle.
The Mandatory Passage is the same as a Leg Bend with the additional
function that it places a Mandatory Passage description in the control
description sheet.

)

X

Control Code

If the normal control symbol or taped control symbol is selected, a dialog
box will appear to enable you to enter a control code (pressing (Ctl)+(n) will
also display this dialog box). The dialog box provides a drop down list of
control codes already in use. A warning is provided if you use a control code
which is already in use or a code which you have declared to be unsuitable.
Unsuitable codes are set with the [Sefiings| options under File » Settings.

Punch Pins

When the control code is entered, Corpse will interrogate the file “Corpse.pch”
to see if a punch pattern exists for this control code and will update the
punch pattern in the dialog box. A punch pattern can be entered manually
by (click)ing on the pins in the punch pattern to turn them on or off. Black
indicates a punch pin, while white indicates no pin.

You may also change the number of pins in a punch by (click)ing the up or
down arrows beside the punch pin editing display. The default number of pins
used when creating a new punch can be set with the options under
File » Settings.

Pre-Start Distance

If the start triangle symbol is selected, a dialog box will appear to enter a
pre-start distance in metres from the start area to the start triangle. After a
pre-start distance is entered, the course length will then contain this distance.
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» Column C - Which Feature

To assign a symbol, (click) and hold over the which feature box to activate a
flyout menu which offers a choice of symbols. Move the cursor to the desired
symbol and release the mouse button.

To clear this item, select the blank square on the flyout menu.

» Column D - Control Feature
Refer to the procedure outlined for column C.

» Column E - Appearance/Feature
Refer to the procedure outlined for column C.

» Column F - Dimensions/Combination

To assign a symbol, (click) and hold over the dimensions box to activate a
flyout menu which offers a number of options. Move the cursor to the desired
option and release the mouse button. If a dimension symbol is selected, then
a dialog box will appear to enable you to enter the relevant dimensions.

g % ID.D ID.D
LCancel |

Dimensions may be entered with a single or no decimal places. This is
achieved by checking the upper checkbox for the left dimension and the lower
checkbox for the right dimension (if one exists). The left box is automatically
updated so that you may preview the dimension as you make changes.

To clear column F, select the blank square on the flyout menu.

» Column G - Marker Location
Refer to the procedure outlined for column C.

» Column H - Other Information
It is possible to enter two symbols in this column.

The first or primary symbol is input using the procedure outlined for column
C.

A second symbol can be entered by holding down the (Ctrl) button before
again using the procedure outlined for column C. The second symbol cannot
exist if the primary symbol does not exist.
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Setting English Descriptions

ABCDETFG
I4 |1E|9|—>|j| F/%l(:)l rfastern boulder, 3.000.5 m, south esst side ||

Corpse will provide a guess at a possible English description based on the symbols
used in the IOF notation. To generate this default double (click) over the English
description on the status bar. To accept this description, press (Enter); to discard it
press (Esc). Alternatively, type your own modifications (up to 100 characters) and
press (Enter) to accept it. If the text includes a “|” then the following text will start
on a new line when printed.

The default description provided for a control corresponding to a marked route will
contain a “#” at the point that a distance would normally appear, for example, “Follow
tapes # metres to finish” . This is to accommodate the fact that this description
describes a leg and not a control position. Whereas the control such as a finish is
fixed, the last legs of different courses start from different controls thus making the
leg length different.

The first “#” is replaced automatically by the appropriate leg length when generating
the English description for the course. You can deactivate this feature by remov-
ing all “#” characters from marked route descriptions. Or you can have your own
marked route descriptions which include a “#”.

Corpse can produce long English descriptions (e.g. north eastern) or short de-
scriptions (e.g. NE). To select the description length, refer to English Control
Descriptions under

Corpse can also produce English descriptions to immediately reflect changes you
have made to the IOF descriptions. To enable this feature, refer to English Control
Descriptions under

Setting Punch Pattern
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The punch pattern for a control is entered with the Control Identifier dialog. This
dialog box can be activated by (click)ing over the punch pattern box on the status
bar or pressing (Ctl)+(n). The punch pattern can also be entered when setting the
control type to a normal or taped control (refer to[Setiing [OF Descriptions).

When the control code is entered, Corpse will interrogate the file “Corpse.pch” to
see if a punch pattern exists for this control code and will update the punch pattern
in the dialog box. A punch pattern can be entered manually by (click)ing on the
pins in the punch pattern to turn them on or off. Black indicates a punch pin, while
white indicates no pin.

You may also change the number of pins in a punch by (click)ing the up or down
arrows beside the punch pin editing display. The default number of pins used when
creating a new punch can be set with the [Sefiings| options under File » Settings.

Setting Leg Climb

The climb involved in getting to the current control from the previous control is
entered in the Leg Climb box on the status bar.

Corpse will total the individual leg climbs for a particular course and place it in the
control descriptions. It will only add the climbs to get to normal controls and taped
controls and the last control. Any climbs associated with leg bends are ignored.

If a climb is entered for a control and the control exists on another course(s) and has
the same previous control or leg bend then the climb will be automatically added to
the other course(s). This means that leg climbs need only be entered once.

Warning Always ensure leg climbs are correct before finally printing course
descriptions. This is best done using the on screen XRef or printed XRef
material. Refer to [XEefl for further information.
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Chapter 9
Cartography

Overview

Cartography mode has been introduced to permit the addition of supplementary
information to the map. These features are called cartographic objects.

Cartographic objects fall into five categories:

Area Object - Enclosed areas which are dangerous or out of bounds.

Line Object - Lines representing boundaries or forbidden routes.

Text Object - A single point which can contain any required text.

Point Object - Single points such as marked crossings, water drops, first aid, etc.

Graphic Object - A single point which can contain any required picture or graphic.

Tools

» Editing Tools

El Change Object

This button is activated when an object is selected and when a symbol is
selected which is compatible with the selected object. For example, an area
can be changed to another area, but not to a point or line symbol.

(Click)ing this button will cause the currently selected object to be changed
to the new symbol. For example, this allows you to change an out of bounds
area to a dangerous area.

If the object is a Text object, Change Object provides a dialog box to enable
you to change the text of the selected object.

il Delete Object
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(Click)ing this button will cause the currently selected object to be deleted.

S Edit Object

When this button is down (click)ing over an object will select it for editing.
The selection process gives priority to point objects.

_[>| Edit Points

When this button is down the individual nodes of an object can be moved or
deleted. New nodes may also be added to area or line cartographic objects.
Refer to following sections on Area Tools, Line Tools, Text Tools, Point Tools
and Rotatable Point Tools.

gl Draw

When this button is down new cartographic objects may be drawn. Refer
to following sections on Area Tools, Line Tools, Text Tools, Point Tools and
Rotatable Point Tools.

» Area Tools

M Out Of Bounds Area - boundary not marked on the ground
ﬂl Out Of Bounds Area - boundary marked continuously on the ground
ﬂl Out Of Bounds Area - boundary marked intermittently on the ground

ﬂl Dangerous Area

To add an area object select the draw tool and the required area tool. Define
the object by (click)ing on the map at adjacent points of the object. When
all points have been defined complete the operation by (click)ing the right
mouse button.

The object can be adjusted by selecting it and dragging the node boxes to
new positions.

New nodes can be added to an object by selecting it then, with the edit points
tool selected, holding down (Ctrl)+(Shift) and (click)ing over the edge of the
object in which you wish to add a new node. The new node can then be
dragged to the desired position.

Nodes can be removed from an object by selecting it then, with the edit points
tool selected, holding down (Ctrl) and (click)ing over the node to be deleted.

Area objects which have less than three nodes (corners) are automatically
deleted.

Area objects cannot be moved. This is achieved by selecting the edit points
tool and dragging the individual nodes to new locations.
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» Line Tools

Ll Uncrossable Boundary
Line objects are created using the steps outlined for Area objects.

Line objects which have less than two nodes (corners) are automatically
deleted.

Line objects cannot be moved. This is achieved by selecting the edit points
tool and dragging the individual nodes to new locations.

» Text Tools
il Text - Text is rendered using the font used for control numbers on maps.

Colour Text - Text can be any font, colour, style and size.

A text object is placed on the map by (click)ing at the desired point with the
draw tool selected. The text will be centred on that point. A dialog window
will appear to enable you to enter the desired text.

The text can be changed by selecting the object and pressing the Change
object tool. A dialog window will appear to enable you to enter the desired
text.

Text objects can be moved by selecting the edit points tool and dragging the
object to the new location.

Text objects which have no text are automatically deleted.
» Point Tools

El Drinks

il Radio Control

il Manned Control

il First Aid

il Hash House

A point object is placed (centred) on the map by (click)ing at the desired point
with the draw tool selected.

Point objects can be moved by selecting the edit points tool and dragging the
object to a new location.

» Rotatable Point Tools

ﬁl Forbidden Route
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ﬂl Crossing Point

A rotatable object is placed on the map by (click)ing at the desired point. If
the mouse button is held down and dragged off to the side, a line will appear
showing the angle to which the object will be rotated when the mouse button
is released.

Rotatable objects can be dragged to new positions by selecting the edit points
tool and dragging the object to the new location.

Rotatable objects can only be rotated at the time of creation. To change the
rotation, delete the object and create a new one at the desired angle.

» Graphics Tools

EI Graphic

A graphics object is placed on the map by (click)ing at the desired point with
the draw tool selected. The graphics object will be centred on that point. A
dialog window will appear to enable you to enter the desired graphics file as
well as to enter its width and height.

The graphics object and its size can be changed by selecting the object and
pressing the Change object tool. A dialog window will appear to enable you
to enter the desired changes.

Graphics objects can be moved by selecting the edit points tool and dragging
the object to the new location.

Graphics objects which have no graphic or no size are automatically deleted.
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Chapter 10
Printing

All printing is conducted through the Print Manager menu. You can access this
menu by selecting File » Print on the menu bar or the &l button on the tool bar.

Printing refers to the production of printed control descriptions sheets, maps, etc.,
as well as the production of EPS files.

Print Control

The Print Manager menu has a number features which control the way in which the
printed product is produced.

» Printer

Use this option to select a printer available to your computer. A dialog box
enables you to select one of the installed Windows printer drivers. (Click)
the Properties button to change the printing options (for instance to print in
landscape mode).

» Copies

A number of copies can be produced by entering a number between 1 and
99 in this edit box. This option only affects the paper printing process. The
number of copies is generated by internally executing the print process the
prescribed number of times. It is far more efficient to use the copies feature
provided by your printer, if one exists.

» Print
(Click) this button to output the maps, control descriptions or EPS files se-
lected. If a selection of items has been chosen then a pick list of items will be
displayed before printing takes place.

» Preview
Preview enables you to view your output prior to printing.
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Note - Every effort has been made to ensure that the preview feature pro-
vides an exact representation of the printed results. There may be minor
variations as the resolution of the preview material is usually much lower than
the resolution on the printer.

» Selection
Select the range of course maps or control descriptions to be printed.
Current - the course currently displayed on the screen.
All - all courses including the master control List.

Selection - a pick list of all courses will be displayed when the print or preview
process is initiated. Highlighted courses will be printed. Select/deselect a
course by (click)ing the course name in the pick list.

» Arrangement
Select the arrangement to print the course control descriptions on the printer
page.
One per page - print each course on a separate page.
Many courses per page - print as many courses on each page as is possible.

Multiple copies per page - print each course on a separate page, as many
copies of that course as will fit are printed on each page.

Always use Preview to check the result prior to printing.

Selecting landscape or portrait page layout can affect the number of courses
printed on each page.

This also applies to the font and print margins used. These settings are
changed with the Preferences located on the[menu barl

Control Descriptions Sheets

» Print Type
Select the type of output required.

Control Descriptions - IOF - print control descriptions sheets in IOF symbol
notation.

Control Descriptions - English - print control descriptions sheets in English.
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Maps

Use this option to print maps.

The maps which are printed are based on the map image you have loaded through
. The printed map will have (at best) the quality of the loaded map.
For example, if an EPS file is loaded with settings of 100 DPI and 256 colours,
the printed map will look very pixelated and the colour of the map will probably be
different from the original map. Best results will be achieved if the map is loaded
with the DPI setting of your printer and colours set to 24 bit colour. The same
applies if you have loaded a BMP file.

When using this option Arrangement is deactivated and maps are printed one per
page. The map(s) are printed using the options you have selected through the
Options button.

If the map file is large, previewing and printing maps may be slow. Depending on
the speed and storage capacity of your computer it may be practicable to only print
and preview maps individually.

Overlays

This option is used when you want to print courses and control descriptions onto
existing maps, usually with your own printer. It is assumed that all output fits onto
one page. The output can also be shifted and scaled using the Overlay Options.

A suggested process for printing overlays is:

e Select two registration points which will appear on the map when printed. Add
these points to the map with the Registration Point tool as described at[Tool|

Bar » IVIap Tools

e Print an overlay with the registration point offsets set to 0;

e For both registration points, measure the distances between the printed over-
lay registration point and the map registration points. Enter these numbers in
the Print Offset boxes provided in Print Options » Overlays. Negative off-
sets will move the printed registration points up and to the left while positive
offsets will move them down and to the right.

e Print another overlay.

Corpse Version 7 — Reference Manual Page 67



e You may need to repeat the adjustment process a number of times to achieve
the desired result.

Note - Overlays cannot be previewed. Use Maps » Preview if required.

EPS Files

The EPS file is the file that is sent to the print shop for printing. In general, the EPS
file will contain the whole map or the purple colour separation along with the course
and control description information. As it is usually expensive (time and money) to
have the resultant EPS files printed, it is essential that they be checked prior to
heading off to the print shop.

EPS output cannot be previewed. Use Maps » Preview to check the output before
creating the EPS files. However, the EPS files created can be viewed using the
EPS Viewer provided on the Utilities » EPS Viewer menu.

Each course selected in the EPS Files » Print process will create a file named
“course name.EPS” in the same directory as the CPE file. Any existing files with
the same name will be automatically overwritten.

When Corpse is asked to create new EPS files during the print process it does this

by firstly copying the base EPS file you have nominated through the [Print » Opfion]
[» EPS » Background File| setting. The course lines and circles, and any control

descriptions, etc. are then overlaid at the end of the copied or new EPS file.

Ensure that you have nominated the correct base EPS file as Corpse has no way
of knowing if the EPS file is the same as the BMP/EPS map file used to create the
courses.

IOF Symbols

Use this option to print a list of IOF symbols and their English translations.

XRef

Use this option to print statistics for the event. Refer to on the [menu bar for
more information
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Punch Patterns

This option prints out the Punch Patterns for controls on a course. All courses are
listed.

Control Codes

This option produces a list of course information for all courses in the orienteer-
ing event. The information includes: course name, length, climb, classes and an
ordered list of control codes.
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Chapter 11
Print Options

General

Use this option to control the way in which Corpse generates printed output and
print files. These preferences are stored in the CPE file with the course and control
descriptions. This means that different files can have different preferences. Fur-
thermore, these preferences are in effect if the file is used on any other computer.

Choose from:

You can save and recall your own preferences using the Save as Defaults and
Load Defaults buttons. These defaults are also used when creating a new CPE
file.

;

Page Margins

Select the white space which is to appear in your printout. The printer you have may
have its own margin settings. The areas specified below are applied to the printable
area provided by the printer. The following settings, specified in millimetres are
available:

Top Margin

Bottom Margin
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Left Margin
Right Margin

Gutter - White space between control description sheets (at the sides and at the
bottom).

Map Options

> Area
Full map - The whole map is printed.
Window - The window defined using the Print Window button on the tool
bar is printed.

» Size

Full size - the map or map window is printed at its original size. If the area to
be printed will not fit on one page it is segmented and printed across several
pages. If segmenting occurs then a 10 millimetre overlap area is provided.

Fit on page - the map or map window is scaled down so that when printed
it will fit on one page. The map proportions are maintained (ratio of width to
height). No scaling occurs if the map will fit on the page full size.

» ldentifiers

Sequence - Consecutive numbers as in the first column of the control de-
scriptions are printed near the control circles.

Control - Control identification numbers as in the second column of the con-
trol descriptions are printed near the control circles. This format is always
used for the master map.

» Approach Arrows

The master control map can be printed with approach arrows corresponding
to the entering and leaving leg lines for each course. This may help when
selecting control marker sites in the field. This option is only available for
maps being printed and does not apply to EPS files.

EPS Options

» EPS Colour
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Select the colour that is used for all Corpse printing on EPS maps. Reference
should be made to International Orienteering Federation guidelines.

Note - The EPS colour should be set to black if you are working with colour
separations of the map. Refer to Corpse, OCAD and CPE for more informa-
tion.

» Stretch Printed Output

When printing courses onto already printed maps there may be a less than
perfect alignment of controls with features on the map. This is typically
caused by distortion in the printing process. The Stretch Printed Output op-
tion gives you the capability of compensating for this affect. The courses
produced by Corpse can be altered by +/- 10%.

Note - Ensure that 100% is selected if maps and courses are being printed
at the same time. If 100% is not selected courses will not match the map.

» Background File

The EPS file produced by Corpse consists of a background with the course
lines, circles, control descriptions overlayed on that background. The back-
ground may be one of:

Template - This will usually be a file which has been produced by OCAD
which contains a copy of the “map” which you have used with Corpse to
compile your courses. Although you can use a different map, by default,
Corpse will use the “map” file you have loaded using it as the template EPS
file. Refer to Map » Load Map on the [nenu barl The end result is a single
EPS file containing both the original map and the course mark up material
(circles, leg lines, control descriptions) from Corpse.

Pristine B/W - This option is used to create a purple layer EPS file. Corpse
creates a blank sheet and lays the course lines, circles, control descriptions
etc in greys on that sheet. This file would then be used for overlay printing
onto existing maps using offset printing processes. The shades of grey in the
EPS file would control the darkness of the print colour in the offset printing
process.

Pristine Colour - This would be used to create a full colour overlay EPS
file. Corpse creates a blank sheet and lays the course lines, circles, control
descriptions etc on that sheet in full colour. This file would then be used for
full colour digital printing onto existing maps.

Overlay Options

Courses can be overlay printed directly from Corpse on to existing maps.
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Select values for print offsets which result in the printed registration points being
printed over the map registration points. A method for determining the offsets is
described at|Print » Overlays|in this manual.

Descriptions - IOF

Use this option to print IOF control descriptions according to options set in Arrange-
ment. The position on the page is managed by the page margins you have selected
through the Options button.

If a control description sheet does not fit in the space available in the current column
then Corpse skips to the top of the next column. Large control description sheets
will be split across a number of columns.

Although English and IOF description sheets cannot be mixed, both can be printed
on the same page by passing the paper through the printer twice and managing
print positions using page margin settings.

Descriptions - English

Use this option to print control descriptions according to options set in Arrange-
ment. The position on the page is managed by the page margins you have selected
through the Options button.

If a control description sheet does not fit in the space available in the current column
then Corpse skips to the top of the next column. Large control description sheets
will be split across a number of columns.

Although English and IOF description sheets cannot be mixed, both can be printed
on the same page by passing the paper through the printer twice and managing
print positions using page margin settings.

Corpse Version 7 — Reference Manual Page 73



Chapter 12
Punch Patterns

Corpse has the capability of producing and using a master list of punch patterns.
This information is stored in the file “Corpse.pch” and records a punch pattern for
each unique control identification code.

To share punch information it is simply a matter of providing a copy of “Corpse.pch”
to other users. The new file must be installed in the same directory as Corpse.exe.

The punch pattern file also caters for recording additional information about the
punch e.g. who has it, condition of the flag, etc. The meaning of this information is
defined by the user. The width of these columns is limited to 50 characters.

To create or update your punch file use Utilities » Punch Patterns.

Editing Punches

» Add a punch description

New punches are added after the currently selected punch. To add a new
punch select Edit » Add Punch or press (Ctrl)+(Ins). The “code” cell will
be selected enabling you to enter the code immediately. Press (Enter) to
complete the operation or (Esc) to abort the operation.

» Alter a punch description

Select from the list displayed, the punch code record and the field to be al-
tered. Press (Enter) to display the current contents in edit mode. If you wish
to replace a field then select the desired cell and commence typing. Press
(Enter) to complete the operation or (Esc) to abort the operation.

If you wish to copy the contents of a cell, select the cell and press (Ctrl)+(C).
Select the target cell and press (Ctrl)+(V). Copying is only permitted across
cells in the same column.

» Delete a punch description

Select the punch code to be deleted from the list displayed. Select Edit »
Delete Punch or press (Ctrl)+(Del) to delete the punch definition.
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All punch records can be deleted by using File » Clear.

» Enter a punch pattern

Select any cell in the desired the punch record. Using the punch pin layout at
the left of the screen left (click) over any pin to set it or right (click) to clear
the pin. A number of pins can be set or cleared by dragging the mouse over
the pins with the left or right button held down.

You may also change the number of pins in a punch by (click)ing the up or
down arrows beside the punch pin editing display.

The default number of pins used when creating a new punch can be set with
the [Setiings| options under File » Settings.
» Move a punch description

You may wish to alter the positions of punch descriptions during the editing
process. This can be achieved by using one of Move Punch Down, Edit »
Move punch Up, (Ctrl)+(D) and (Ctrl)+(U). You may also use the mouse to
drag the punch description up or down in the list.

Other

» Column Headings

The text in the column headings can be changed using Edit » Heading 1.
These headings are stored in the punch file.

» Sorting Punch Records

(Click)ing on the header bar fields relating to “Code”, “Header 1” or “Header
2” will cause the punch records to be sorted according to the data in those
columns. The records will be sorted into ascending and descending order
alternatively.

Records may be sorted prior to printing if required otherwise they will be
printed in the current order.

Note - When the punch records are saved they will be automatically sorted
into ascending order of “Code”.
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Chapter 13
Corpse, OCAD and EPS

Overview

This is a technical note about Corpse, Bitmaps and OCAD. The comments on
OCAD are based on user experience and should be in no way interpreted as scien-
tific fact or opinions of OCAD. For detailed or current information on OCAD please
refer to OCAD product information.

This material attempts to give a basic insight into the interaction between Corpse
and OCAD. If, as a Corpse user, you are dependant on another party (OCAD user)
for the supply of BMP files it is essential that they also be aware of the information
in this section.

The Corpse/OCAD Connection

Corpse can work with two file types produced by OCAD; these are the BMP file and
the EPS file. Corpse assumes that these two files contain exactly the same map in
different formats.

Corpse useseither the BMP file or EPS file to position controls. Corpse can then
superimpose the controls, course descriptions, etc, onto the EPS files that have
been produced by OCAD to produce high quality course maps for the orienteer. If
a combination of BMP and EPS files is to be used, it is essential that the BMP file
and the EPS file are exactly the same. To ensure that this is the case, produce
both the BMP file (use the export function in the file menu of OCAD) and the EPS
file (using the print function of OCAD) at the same time.

Note - It is essential that the print window is set to map size before producing the
EPS file.
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Bitmaps

» Requirements
The requirement for the Corpse user is to have a bitmap which:

(a) Shows adequate detail. The detail visible on the bitmap is increased by
increasing the DPI (dots per inch) in the bitmap.

(b) Enables Corpse to operate at a reasonable speed or better. The smaller
the bitmap that Corpse has to deal with the faster it will operate.

As you can see, requirements (a) and (b) are in direct conflict. Increasing the
visible detail (by increasing the DPI of the bitmap) creates a bigger file. The
bigger file slows down Corpse. Where you strike the balance is dependant
on personal choice and compute power at your disposal.

» Colour

The colour quality of the map is not very important and can be sacrificed in an
effort to better meet (a) or (b) above. Although OCAD users probably operate
in 64,000 colour mode or higher, 256 colours is perfectly adequate for course
setting.

If speed is an issue, it is not just enough to create a bitmap at 256 colours
(for example) and then run your computer with a display setting of 16 million
colours. Every time Corpse displays the map, Windows translates the map
back to 16 million colours.

» Detail Versus Speed

The table below should give you some appreciation of the interaction between
colour, DPI and the size of the resultant BMP file.

BMP File Size - Bytes Per Square CM
Colours \DPI | 100 150 200 250

16 388 872 1,550 2,422
256 1,550 3,488 6,200 9,688
64,000 6,200 13,950 24,800 38,750
16M 13,950 31,388 55,800 87,188

For Little Bombay, a map of around 39cm x 44cm, a file of 10mb is required
at 200 DPI and 256 colours. At 200 DPI and 16M colours it is around 90 mb.

» Recommendation

For Corpse work, a bitmap of 200 DPI or more gives adequate detail. In
complex granite, the higher the better. It is better to provide a map that has
too much detail than one with too low a DPI. Corpse can reduce the detail
with its ‘Tailor Map’ facility but it cannot create the detail.
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» OCAD

Producing bitmaps (BMP files) via OCAD has a few hidden traps. My experi-
ence is with OCAD 6, the issues could be different for later versions.

When working in OCAD, some mappers use the HATCHED AREA feature.
This displays solid areas as stripes. If you use the export bitmap facility to
produce a BMP file the BMP file will also have stripes and not solid colours.
Therefore, before producing the BMP file make sure that the HATCHED AREA
feature is not turned on.

You may have noticed by now that OCAD (6) has some internal barrier which
prevents it from producing bitmaps with a higher DPI. | have observed that
this limit is when the resultant BMP file hits a size of around 16mb. On larger
maps (such as Little Bombay) the map has to be cut down and the DPI re-
duced to 150 DPI to get any sort of map.

For most computer setups, OCAD produces a bitmap with 16 million colours.
This typically produces a large file with more colours than you can see and
certainly more than is required for course setting.

It is possible to get OCAD to produce a 256 colour bitmap. This permits
the production of a bitmap with around 50% higher resolution before hitting
OCAD’s 16mb barrier. To achieve this, set the screen colours on your com-
puter to 256 before opening OCAD to produce the BMP file. Screen colours
are set through Windows (Settings/Control Panel/Display) and can be done
without re-booting the computer. You can return the colour setting to its pre-
vious value in the same way.

EPS

EPS Explained

The Encapsulated PostScript (EPS) language file format is an industry standard
format for the exchange of print files. This is the format most commonly used in the
printing of Orienteering maps.

In general terms, OCAD produces maps using a colour palette comprised of black,
blue, brown, green, yellow, purple and grey. These colours represent the features
on an orienteering map. OCAD produces two types of map:

Colour Map - All colours are printed. This represents the map that you use when
orienteering.

Colour Separations - A map is printed a single colour at a time. If these were
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printed on clear film then laying all films on top of each other would produce the full
colour map.

Colour separations are special prints used in the printing industry. Of importance
is that, for example, a purple separation is not purple; it is black. When used in the
print process, the presence of black represents where the printer is to place ink on
the map (the printer must be told the colour of the ink to be used). Whether the
colour is a light or dark shade is signified by the shade of black (greyness) on the
separation. Black signifies to deposit a lot of ink while light grey signifies to deposit
only a thin layer of ink.

On the other hand, the full colour map EPS file has the information for all colours
defined in it. As such, the colours are actually defined as colours. This leads to the
following peculiarity:

1. If Corpse is being used to superimpose courses onto a colour map file, you
must set the EPS colour to the correct shade of purple.

2. If Corpse is being used to superimpose courses onto a purple colour sep-
aration, you must set the EPS colour to black. The shade of purple will be
established at the time of printing and by the shade of black which you specify
with Corpse.

OCAD EPS Implementation

The EPS system is an extensive printing process capable of rendering typeset
books, photographs and artwork. At this time the implementation of EPS by OCAD
requires only part of the full EPS capability.

CORPSE EPS Implementation

Corpse has an EPS interpret function which can interpret EPS files generated by
OCAD and Corpse. This interpreter may or may not be able to successfully read
EPS files created by other packages.

The EPS interpreter has been developed as a separate module of the Corpse pack-
age. Should OCAD change the way it implements the EPS facility, then it is intended
to make available an upgraded EPS interpreter for Corpse without needing to up-
grade Corpse itself.

The Corpse EPS interpreter has been optimised to process the range of EPS com-
mands used by OCAD at this time. This allows Corpse to load EPS files faster. The
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optimisation capability can be turned off should problems arise with loading EPS
files.

Hint If you have an EPS file which Corpse cannot load with its own interpreter then
you can use a product such as Adobe Photoshop to create a BMP file from the EPS
file.

EPS Advantages

The Corpse user can gain a number of advantages from using EPS files generated
by OCAD:

1. The EPS file is likely to be much smaller than the equivalent BMP file.

2. Corpse can vary the map’s detail and colour at load time. These parameters
can be increased or decreased as desired.

3. If courses are to be added to EPS files, the problem of ensuring that the BMP
file used by Corpse and the EPS files to be overprinted match, is virtually
eliminated. An EPS Viewer has been provided with Corpse. This viewer en-
ables you to view EPS files created by Corpse. It is also capable of overlaying
course files onto a base map file.
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Chapter 14
Performance Issues

This section identifies factors which will affect the overall performance of Corpse.
Performance in this instance covers the speed of operation as well as the quality of
the results provided by Corpse.

The topics covered are generally restricted to those over which you have some
control and can influence with your current equipment and how you use it.

Poor Print Quality

Shading in IOF control descriptions If your printer has a “dither” option ensure
that it is set to “none” when printing IOF control descriptions. Dither was not found
to have any affect when printing English control descriptions.

Slow Performance

» Large MAP file

Large map files take a long time to load and consume a lot of system re-
sources to manage. Slowness can be experienced when changing course
views if the computer has limited amounts of memory.

» Map Colours

Best performance is achieved if the number of colours of the map BMP file is
the same as the computer’s screen capability. If your map has been scanned
with 16 million colours but your computer screen is configured at 256 colours
the computer has to translate from 16 million to 256 every time the map is
refreshed. The map is refreshed frequently, including every time a control is
moved, added or its number changes.

» Screen Colours
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If your map has 256 colours, best performance is achieved by setting the
screen colours to 256 while using Corpse. The screen can be temporarily
set to 256 colours through Windows/Settings without having to re-boot the
computer.

» Preview

The preview option stores a complete page image for each page previewed.
These can take a significant amount of time to generate and may consume
all system resources if a large number of pages are previewed.

When leaving the preview function the system has to reclaim all space used
by the preview function. The system may use all of its energy doing this
reclaim and forget to talk to you. The symptom is a lot of disk activity.

The obvious solution is to only preview what you want to look at. It may be
necessary to preview material in segments which your computer can handle
comfortably.

» Holes and Cartographic Objects

Only add items such as “holes”, breaks in control circles and cartographic
objects after the main course planning has been completed. The display of
cartographic objects can be deactivated.

» Excess Objects
Remove unwanted controls, holes and cartographic objects.

Detail Missing in Preview

The preview option permits the user to see what the printed result will look like
when it is printed. To conserve computer resources, the preview is generated at
a much lower resolution than your printer. This leads to some lines disappearing
when previewed. It also causes objects in IOF boxes to look as though they are off
to one side or the two circles for the finish to not be concentric.

In extreme circumstances it “may” be possible for the printed result to be different
from the previewed result. This is brought about by scaling of images between two
different sized pages and mathematical rounding in calculations which may occur
during the process.
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Looks Different

You may notice that text will wrap differently on different computers; the ability to fit
text into IOF boxes may also vary. If you print course descriptions at 180 DPI, for
example, letters in text will typically take up more space on the page than if it was
printed at 360 DPI.

For consistent results, always print with the same DPI setting for the output printer.
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Chapter 15
Speed Keys

» Course Setting

(Ctrl)+(N) - Display the Control Identifier window enabling input of a control

identifier or punch pattern for the currently selected control
(Ctrl)+(0) - Display the Open File menu

Ctrl)+(S) - Save the current file

Ctrl)+(+) - Zoom in

Ctrl)+(-) - Zoom out

Ctrl)+(Delete) - Delete the currently active control

{
{
{
{

(Ctrl)+(up arrow) - Move the active control one position closer to the start of
the course

(Ctrl)+(down arrow) - Move the active control one position closer to the end
of the course

(up arrow) - Change focus to the preceding course control
(down arrow) - Change focus to the next course control

(Shift)+(right arrow) - Shift the active control one pixel to the right on the
map

(Shift)+(left arrow) - Shift the active control one pixel to the left on the map
(Shift)+(up arrow) - Shift the active control one pixel upwards on the map

(Shift)+(down arrow) - Shift the active control one pixel downwards on the
map

(PgUp) - Display the course one to the right of the current course
(PgDown) - Display the course one to the left of the current course
(F5) - Refresh display

» Quick Entry
(Enter) - Start editing the current cell
(Ctrl)+(C) - Copy the current cell
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(Ctrl)+(V) - Paste the current cell

(Ctrl)+(X) - Cut the current cell

(Ctrl)+(Insert) - Insert a new course after the currently selected course
(Ctrl)+(Delete) - Delete the currently selected course
(Ctrl)+(U
(Ctrl)+(D) - Move the currently selected course down one position

) - Move the currently selected course up one position

» Punch Management

(Ctrl)+(S) - Save the current file

(Enter) - Start editing the current cell

(Ctrl)+(C) - Copy the current cell
(Ctrl)+(V) - Paste the current cell
(Ctrl)+(X) - Cut the current cell
(Ctrl)+(Insert) - Insert a new punch after the currently selected punch
(Ctrl)+(Delete) - Delete the currently selected punch
(Ctrl)+(U) - Move the currently selected punch up one position

)+

(Ctrl)+(D) - Move the currently selected punch down one position

» XRef
(Ctrl)+(C) - Copy the XRef data to the clipboard

» EPS Viewer
(Ctrl)+(L) - Load a new EPS file
(Ctrl)+(0) - Overlay another EPS file
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Chapter 16
Glossary

cartographic object These are additional markings placed on the map to indicate
important locations for this event. These symbols denote the location of first aid,
water drops, manned controls, safe crossings, out of bounds areas, etc.

control descriptions sheet A description of controls (sequence numbers, iden-
tification numbers, site characteristics) provided to competitors on a course of an
orienteering event. Control descriptions sheets can be written in English or IOF
symbols.

CMYK Acronym for cyan, magenta, yellow and black; the four colours used in the
standard model in the printing industry. Refers to a method of specifying colour
using CMYK colour values. (K is used for black)

course hame Course name is the descriptive name given to the orienteering
course, e.g. RED 1.

CPE CPE is the file extension used for files created and used by Corpse.
Corpse Course Planning and Setting (this software package).

DPI Quality of a graphics image measured in dots per inch. This applies to scanned
images (or maps) as well as printed documents.

EPS The Encapsulated PostScript (EPS) language file format is an industry stan-
dard format for the exchange of print files. This is the format most commonly used
in the printing of Orienteering maps.

event name The descriptive name of the orienteering event printed in the top box
of each course control descriptions sheet.

leg bend Leg bends are depicted on the screen map as small circles. These
circles do not appear on any printed maps. Leg bends enable you to change a leg
line from a straight line to one with bends. The bend does not affect the leg line
type (dashed or solid) but does affect the leg length. A number of leg bends can be
placed between any two controls.

map The map is a Windows BMP file which contains an image of the area in which
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the orienteering event is to be held. It may be a complete orienteering map or a
segment of an orienteering map.

OCAD A commercially available computer aided drawing package for orienteering
maps.
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